p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache-airflow-providers-mysql

Vulnerabilidades publicadas para apache-airflow-providers-mysql en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2025-27018

    Media · CVSS 6.3EPSS 0,91%Corrección disponible

    Apache Airflow MySQL Provider: SQL injection in MySQL provider core function

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.

    • Actualiza a 6.2.0
    Publicación Actualización
  2. CVE-2023-22884

    Crítica · CVSS 9.8EPSS 11,08%Corrección disponible

    Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow

    Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.

    • Actualiza a 4.0.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →