CVE-2025-3015
CVE-2025-3015 · Open Asset Import Library Assimp ASE File ASELoader.cpp BuildUniqueRepresentation out-of-bounds
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability classified as critical has been found in Open Asset Import Library Assimp 5.4.3. This affects the function Assimp::ASEImporter::BuildUniqueRepresentation of the file code/AssetLib/ASE/ASELoader.cpp of the component ASE File Handler. The manipulation of the argument mIndices leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 6.0 is able to address this issue. The patch is named 7c705fde418d68cca4e8eff56be01b2617b0d6fe. It is recommended to apply a patch to fix this issue.
CVSS 5.3 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
assimp
- Versiones
- 5.4.3: Afectada
Sin corrección publicada
assimp Debian:12
- Versiones
- 5.2.5~ds0-1
- 5.2.5~ds0-1.1
- 5.3.1+ds-1
- 5.3.1+ds-2
- 5.4.0+ds-1
- 5.4.1+ds-1
- 5.4.2+ds-1
- 5.4.3+ds-2
- 5.4.3+ds-3
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-3
- 6.0.5+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Debian:13
- Versiones
- 5.4.3+ds-2
- 5.4.3+ds-3
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-3
- 6.0.5+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Debian:14
- Versiones
- 5.4.3+ds-2
- 5.4.3+ds-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.0.2+ds-1
Actualiza a 6.0.2+ds-1
pyassimp PyPI
- Versiones
- 0.1
- 3.3
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 5.2.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≤ 5.4.3
Sin corrección publicada
assimp Ubuntu:16.04:LTS
- Versiones
- 3.0~dfsg-4ubuntu4
- 3.1.1~dfsg-5
- 3.2~dfsg-1
- 3.2~dfsg-2
- 3.2~dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:18.04:LTS
- Versiones
- 3.3.1~dfsg-5
- 3.3.1~dfsg-5ubuntu1
- 3.3.1~dfsg-5+build1
- 4.0.1~dfsg-1~exp2
- 4.0.1~dfsg-1
- 4.1.0~dfsg-1
- 4.1.0~dfsg-2
- 4.1.0~dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:20.04:LTS
- Versiones
- 4.1.0~dfsg-5
- 4.1.0~dfsg-5ubuntu1
- 5.0.1~ds0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:22.04:LTS
- Versiones
- 5.0.1~ds0-2
- 5.0.1~ds0-3ubuntu1
- 5.1.4~ds0-1
- 5.1.5~ds0-1
- 5.1.6~ds0-1
- 5.2.0~ds0-2
- 5.2.1~ds0-1
- 5.2.2~ds0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:24.04:LTS
- Versiones
- 5.2.5~ds0-1.1build1
- 5.3.1+ds-1
- 5.3.1+ds-2
- 5.3.1+ds-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:25.10
- Versiones
- 5.4.3+ds-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:26.10
- Versiones
- 6.0.4+ds-1build1
- 6.0.5+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
assimp Ubuntu:26.04:LTS
- Versiones
- 5.4.3+ds-2
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://vuldb.com/?id.302067
- https://vuldb.com/?ctiid.302067
- https://vuldb.com/?submit.524589
- https://github.com/assimp/assimp/issues/6021
- https://github.com/assimp/assimp/pull/6045
- https://github.com/assimp/assimp/issues/6021#issue-2877378829
- https://github.com/assimp/assimp/commit/7c705fde418d68cca4e8eff56be01b2617b0d6fe
- https://nvd.nist.gov/vuln/detail/CVE-2025-3015