CVE-2025-3015
CVE-2025-3015 · Open Asset Import Library Assimp ASE File ASELoader.cpp BuildUniqueRepresentation out-of-bounds
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
A vulnerability classified as critical has been found in Open Asset Import Library Assimp 5.4.3. This affects the function Assimp::ASEImporter::BuildUniqueRepresentation of the file code/AssetLib/ASE/ASELoader.cpp of the component ASE File Handler. The manipulation of the argument mIndices leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 6.0 is able to address this issue. The patch is named 7c705fde418d68cca4e8eff56be01b2617b0d6fe. It is recommended to apply a patch to fix this issue.
CVSS 5.3 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
assimp
- Versions du logiciel
- 5.4.3: Concernée
Aucun correctif publié
assimp Debian:12
- Versions du logiciel
- 5.2.5~ds0-1
- 5.2.5~ds0-1.1
- 5.3.1+ds-1
- 5.3.1+ds-2
- 5.4.0+ds-1
- 5.4.1+ds-1
- 5.4.2+ds-1
- 5.4.3+ds-2
- 5.4.3+ds-3
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-3
- 6.0.5+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Debian:13
- Versions du logiciel
- 5.4.3+ds-2
- 5.4.3+ds-3
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-3
- 6.0.5+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Debian:14
- Versions du logiciel
- 5.4.3+ds-2
- 5.4.3+ds-3
- Plages de versions concernées
- ECOSYSTEM: < 6.0.2+ds-1
Mettez à jour vers 6.0.2+ds-1
pyassimp PyPI
- Versions du logiciel
- 0.1
- 3.3
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 5.2.5
- Plages de versions concernées
- ECOSYSTEM: ≤ 5.4.3
Aucun correctif publié
assimp Ubuntu:16.04:LTS
- Versions du logiciel
- 3.0~dfsg-4ubuntu4
- 3.1.1~dfsg-5
- 3.2~dfsg-1
- 3.2~dfsg-2
- 3.2~dfsg-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:18.04:LTS
- Versions du logiciel
- 3.3.1~dfsg-5
- 3.3.1~dfsg-5ubuntu1
- 3.3.1~dfsg-5+build1
- 4.0.1~dfsg-1~exp2
- 4.0.1~dfsg-1
- 4.1.0~dfsg-1
- 4.1.0~dfsg-2
- 4.1.0~dfsg-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:20.04:LTS
- Versions du logiciel
- 4.1.0~dfsg-5
- 4.1.0~dfsg-5ubuntu1
- 5.0.1~ds0-1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:22.04:LTS
- Versions du logiciel
- 5.0.1~ds0-2
- 5.0.1~ds0-3ubuntu1
- 5.1.4~ds0-1
- 5.1.5~ds0-1
- 5.1.6~ds0-1
- 5.2.0~ds0-2
- 5.2.1~ds0-1
- 5.2.2~ds0-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:24.04:LTS
- Versions du logiciel
- 5.2.5~ds0-1.1build1
- 5.3.1+ds-1
- 5.3.1+ds-2
- 5.3.1+ds-2build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:25.10
- Versions du logiciel
- 5.4.3+ds-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:26.10
- Versions du logiciel
- 6.0.4+ds-1build1
- 6.0.5+ds-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
assimp Ubuntu:26.04:LTS
- Versions du logiciel
- 5.4.3+ds-2
- 6.0.2+ds-1
- 6.0.3+ds-1
- 6.0.4+ds-1
- 6.0.4+ds-1build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://vuldb.com/?id.302067
- https://vuldb.com/?ctiid.302067
- https://vuldb.com/?submit.524589
- https://github.com/assimp/assimp/issues/6021
- https://github.com/assimp/assimp/pull/6045
- https://github.com/assimp/assimp/issues/6021#issue-2877378829
- https://github.com/assimp/assimp/commit/7c705fde418d68cca4e8eff56be01b2617b0d6fe
- https://nvd.nist.gov/vuln/detail/CVE-2025-3015