p PatchFirst

CVE-2025-30152

CVE-2025-30152 · Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. Prior to 1.6.2, 1.7.2, and 2.0.2, a discovered vulnerability allows users to modify their shopping cart after completing the PayPal Checkout process and payment authorization. If a user initiates a PayPal transaction from a product page or the cart page and then returns to the order summary page, they can still manipulate the cart contents before finalizing the order. As a result, the order amount in Sylius may be higher than the amount actually captured by PayPal, leading to a scenario where merchants deliver products or services without full payment. The issue is fixed in versions: 1.6.2, 1.7.2, 2.0.2 and above.

CVSS 6.5 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • paypalplugin

    Versiones
    • < 1.6.2: Afectada
    • >= 1.7.0, < 1.7.2: Afectada
    • >= 2.0.0, < 2.0.2: Afectada

    Sin corrección publicada

  • sylius/paypal-plugin Packagist

    Versiones
    • v0.1.0
    • v0.1.1
    • v0.2.0
    • v0.2.1
    • v0.3.0
    • v0.3.1
    • v1.0.0
    • v1.0.0-BETA.1
    • v1.0.0-BETA.2
    • v1.0.0-BETA.3
    • v1.0.0-BETA.4
    • v1.0.0-RC.1
    • v1.0.0-RC.2
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.1.1
    • v1.2.0
    • v1.2.1
    • v1.2.2
    • v1.2.3
    • v1.2.4
    • v1.3.0
    • v1.3.1
    • v1.3.2
    • v1.4.0
    • v1.4.1
    • v1.4.2
    • v1.5.0
    • v1.5.1
    • v1.5.2
    • v1.5.3
    • v1.6.0
    • v1.6.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.2

    Actualiza a 1.6.2

  • sylius/paypal-plugin Packagist

    Versiones
    • v1.7.0
    • v1.7.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 1.7.0, < 1.7.2

    Actualiza a 1.7.2

  • sylius/paypal-plugin Packagist

    Versiones
    • v2.0.0
    • v2.0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.2

    Actualiza a 2.0.2

Fuentes originales

Comprueba tu servidor →