CVE-2025-30152
CVE-2025-30152 · Sylius PayPal Plugin has an Order Manipulation Vulnerability after PayPal Checkout
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. Prior to 1.6.2, 1.7.2, and 2.0.2, a discovered vulnerability allows users to modify their shopping cart after completing the PayPal Checkout process and payment authorization. If a user initiates a PayPal transaction from a product page or the cart page and then returns to the order summary page, they can still manipulate the cart contents before finalizing the order. As a result, the order amount in Sylius may be higher than the amount actually captured by PayPal, leading to a scenario where merchants deliver products or services without full payment. The issue is fixed in versions: 1.6.2, 1.7.2, 2.0.2 and above.
CVSS 6.5 · Moyenne · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: php
Produits et versions concernés
paypalplugin
- Versions du logiciel
- < 1.6.2: Concernée
- >= 1.7.0, < 1.7.2: Concernée
- >= 2.0.0, < 2.0.2: Concernée
Aucun correctif publié
sylius/paypal-plugin Packagist
- Versions du logiciel
- v0.1.0
- v0.1.1
- v0.2.0
- v0.2.1
- v0.3.0
- v0.3.1
- v1.0.0
- v1.0.0-BETA.1
- v1.0.0-BETA.2
- v1.0.0-BETA.3
- v1.0.0-BETA.4
- v1.0.0-RC.1
- v1.0.0-RC.2
- v1.0.1
- v1.0.2
- v1.0.3
- v1.0.4
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.2.2
- v1.2.3
- v1.2.4
- v1.3.0
- v1.3.1
- v1.3.2
- v1.4.0
- v1.4.1
- v1.4.2
- v1.5.0
- v1.5.1
- v1.5.2
- v1.5.3
- v1.6.0
- v1.6.1
- Plages de versions concernées
- ECOSYSTEM: < 1.6.2
Mettez à jour vers 1.6.2
sylius/paypal-plugin Packagist
- Versions du logiciel
- v1.7.0
- v1.7.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.7.0, < 1.7.2
Mettez à jour vers 1.7.2
sylius/paypal-plugin Packagist
- Versions du logiciel
- v2.0.0
- v2.0.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 2.0.0, < 2.0.2
Mettez à jour vers 2.0.2