p PatchFirst

CVE-2025-30167

CVE-2025-30167 · Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).

CVSS 7.3 · Alta · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • jupyter_core

    Versiones
    • < 5.8.0: Afectada

    Sin corrección publicada

  • jupyter-core PyPI

    Versiones
    • 4.0.0
    • 4.0.0.dev
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    • 4.0.6
    • 4.1.0
    • 4.1.1
    • 4.10.0
    • 4.11.0
    • 4.11.1
    • 4.11.2
    • 4.12.0
    • 4.2.0
    • 4.2.1
    • 4.3.0
    • 4.4.0
    • 4.5.0
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 4.6.3
    • 4.7.0
    • 4.7.0rc0
    • 4.7.1
    • 4.8.0
    • 4.8.0b0
    • 4.8.0rc0
    • 4.8.0rc1
    • 4.8.1
    • 4.8.2
    • 4.9.0
    • 4.9.0rc0
    • 4.9.1
    • 4.9.1rc0
    • 4.9.2
    • 5.0.0
    • 5.0.0rc0
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.1.0
    • 5.1.1
    • 5.1.2
    • 5.1.3
    • 5.1.4
    • 5.1.5
    • 5.2.0
    • 5.3.0
    • 5.3.1
    • 5.3.2
    • 5.4.0
    • 5.5.0
    • 5.5.1
    • 5.6.0
    • 5.6.1
    • 5.7.0
    • 5.7.1
    • 5.7.2
    • 5.8.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.8.1

    Actualiza a 5.8.1

  • jupyter-core Ubuntu:Pro:18.04:LTS

    Versiones
    • 4.3.0-1
    • 4.4.0-1
    • 4.4.0-2
    • 4.4.0-2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:Pro:20.04:LTS

    Versiones
    • 4.5.0-2
    • 4.6.0-1
    • 4.6.1-1
    • 4.6.2-1ubuntu1
    • 4.6.3-3
    • 4.6.3-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:Pro:22.04:LTS

    Versiones
    • 4.7.1-1
    • 4.9.1-1
    • 4.9.1-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:24.04:LTS

    Versiones
    • 5.3.1-1
    • 5.3.2-1
    • 5.3.2-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:25.10

    Versiones
    • 5.7.2-5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:26.10

    Versiones
    • 5.9.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jupyter-core Ubuntu:26.04:LTS

    Versiones
    • 5.7.2-5
    • 5.9.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →