p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de jupyter-core

Vulnerabilidades publicadas para jupyter-core en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2025-30167

    Alta · CVSS 7.3EPSS 0,2%Sin corrección publicada

    Jupyter Core on Windows Has Uncontrolled Search Path Element Local Privilege Escalation Vulnerability

    Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by u

    Publicación Actualización
  2. CVE-2022-39286

    Alta · CVSS 8.8EPSS 1,45%Corrección disponible

    Execution with Unnecessary Privileges in JupyterApp

    Jupyter Core is a package for the core common functionality of Jupyter projects. Jupyter Core prior to version 4.11.2 contains an arbitrary code execution vulnerability in `jupyter_core` that stems from `jupyter_core` executing untrusted files in CWD. This vulnerability allows one user to run code as another. Version 4.11.2 contains a patch for this issue. There are no known workarounds.

    • Actualiza a 4.9.1-1ubuntu0.1~esm1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →