p PatchFirst

CVE-2025-46337

CVE-2025-46337 · SQL injection in ADOdb PostgreSQL driver pg_insert_id() method

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.

CVSS 10.0 · Crítica · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · php

Productos y versiones afectados

  • adodb

    Versiones
    • < 5.22.9: Afectada

    Sin corrección publicada

  • libphp-adodb Debian:12

    Versiones
    • 5.21.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.21.4-1+deb12u1

    Actualiza a 5.21.4-1+deb12u1

  • libphp-adodb Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.22.9-0.1

    Actualiza a 5.22.9-0.1

  • libphp-adodb Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.22.9-0.1

    Actualiza a 5.22.9-0.1

  • adodb/adodb-php Packagist

    Versiones
    • v5.19
    • v5.20.0
    • v5.20.1
    • v5.20.10
    • v5.20.11
    • v5.20.12
    • v5.20.13
    • v5.20.14
    • v5.20.15
    • v5.20.16
    • v5.20.17
    • v5.20.18
    • v5.20.19
    • v5.20.2
    • v5.20.20
    • v5.20.21
    • v5.20.3
    • v5.20.4
    • v5.20.5
    • v5.20.6
    • v5.20.7
    • v5.20.8
    • v5.20.9
    • v5.21.0
    • v5.21.0-beta.1
    • v5.21.0-rc.1
    • v5.21.1
    • v5.21.2
    • v5.21.3
    • v5.21.4
    • v5.22.0
    • v5.22.1
    • v5.22.2
    • v5.22.3
    • v5.22.4
    • v5.22.5
    • v5.22.6
    • v5.22.7
    • v5.22.8
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.22.9

    Actualiza a 5.22.9

  • libphp-adodb Ubuntu:Pro:16.04:LTS

    Versiones
    • 5.18a-1
    • 5.20.1-1
    • 5.20.2-1
    • 5.20.2-2
    • 5.20.3-1
    • 5.20.3-1ubuntu1
    • 5.20.3-1ubuntu1+esm1
    • 5.20.3-1ubuntu1+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libphp-adodb Ubuntu:Pro:20.04:LTS

    Versiones
    • 5.20.14-1
    • 5.20.15-1
    • 5.20.16-1
    • 5.20.16-1ubuntu0.1~esm1
    • 5.20.16-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libphp-adodb Ubuntu:Pro:22.04:LTS

    Versiones
    • 5.20.19-1
    • 5.20.19-1ubuntu0.1
    • 5.20.19-1ubuntu0.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libphp-adodb Ubuntu:Pro:24.04:LTS

    Versiones
    • 5.21.4-1
    • 5.21.4-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libphp-adodb Ubuntu:25.10

    Versiones
    • 5.22.8-0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.22.9-0.1

    Actualiza a 5.22.9-0.1

  • libphp-adodb Ubuntu:26.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.22.9-0.1

    Actualiza a 5.22.9-0.1

Fuentes originales

Comprueba tu servidor →