CVE-2025-46337
CVE-2025-46337 · SQL injection in ADOdb PostgreSQL driver pg_insert_id() method
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
CVSS 10.0 · Kritisch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
adodb
- Softwareversionen
- < 5.22.9: Betroffen
Keine Korrektur veröffentlicht
libphp-adodb Debian:12
- Softwareversionen
- 5.21.4-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.21.4-1+deb12u1
Auf 5.21.4-1+deb12u1 aktualisieren
libphp-adodb Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.22.9-0.1
Auf 5.22.9-0.1 aktualisieren
libphp-adodb Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.22.9-0.1
Auf 5.22.9-0.1 aktualisieren
adodb/adodb-php Packagist
- Softwareversionen
- v5.19
- v5.20.0
- v5.20.1
- v5.20.10
- v5.20.11
- v5.20.12
- v5.20.13
- v5.20.14
- v5.20.15
- v5.20.16
- v5.20.17
- v5.20.18
- v5.20.19
- v5.20.2
- v5.20.20
- v5.20.21
- v5.20.3
- v5.20.4
- v5.20.5
- v5.20.6
- v5.20.7
- v5.20.8
- v5.20.9
- v5.21.0
- v5.21.0-beta.1
- v5.21.0-rc.1
- v5.21.1
- v5.21.2
- v5.21.3
- v5.21.4
- v5.22.0
- v5.22.1
- v5.22.2
- v5.22.3
- v5.22.4
- v5.22.5
- v5.22.6
- v5.22.7
- v5.22.8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.22.9
Auf 5.22.9 aktualisieren
libphp-adodb Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 5.18a-1
- 5.20.1-1
- 5.20.2-1
- 5.20.2-2
- 5.20.3-1
- 5.20.3-1ubuntu1
- 5.20.3-1ubuntu1+esm1
- 5.20.3-1ubuntu1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libphp-adodb Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5.20.14-1
- 5.20.15-1
- 5.20.16-1
- 5.20.16-1ubuntu0.1~esm1
- 5.20.16-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libphp-adodb Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 5.20.19-1
- 5.20.19-1ubuntu0.1
- 5.20.19-1ubuntu0.1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libphp-adodb Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 5.21.4-1
- 5.21.4-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
libphp-adodb Ubuntu:25.10
- Softwareversionen
- 5.22.8-0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.22.9-0.1
Auf 5.22.9-0.1 aktualisieren
libphp-adodb Ubuntu:26.04:LTS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.22.9-0.1
Auf 5.22.9-0.1 aktualisieren
Originalquellen
- https://github.com/ADOdb/ADOdb/security/advisories/GHSA-8x27-jwjr-8545
- https://github.com/ADOdb/ADOdb/issues/1070
- https://github.com/ADOdb/ADOdb/commit/11107d6d6e5160b62e05dff8a3a2678cf0e3a426
- https://xaliom.blogspot.com/2025/05/from-sast-to-cve-2025-46337.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00029.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-46337