CVE-2025-47291
CVE-2025-47291 · containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.
CVSS 4.6 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · containers
Productos y versiones afectados
containerd
- Versiones
- >= 2.0.1, < 2.0.5: Afectada
Sin corrección publicada
containerd-app Ubuntu:25.10
- Versiones
- 2.0.2-0ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.5-0ubuntu1
Actualiza a 2.0.5-0ubuntu1