CVE-2025-47291
CVE-2025-47291 · containerd CRI plugin: Incorrect cgroup hierarchy assignment for containers running in usernamespaced Kubernetes pods.
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.
CVSS 4.6 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · containers
Betroffene Produkte und Versionen
containerd
- Softwareversionen
- >= 2.0.1, < 2.0.5: Betroffen
Keine Korrektur veröffentlicht
containerd-app Ubuntu:25.10
- Softwareversionen
- 2.0.2-0ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.5-0ubuntu1
Auf 2.0.5-0ubuntu1 aktualisieren