CVE-2025-48431
CVE-2025-48431 · Apache Thrift: Specially crafted input can crash a c_glib Thrift server with invalid pointer error.
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Mismatched Memory Management Routines vulnerability in Apache Thrift c_glib language bindings. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. Description: Specially crafted requests can crash an c_glib-based Thrift server with a clean but fatal "free(): invalid pointer" error message.
CVSS 7.5 · Alta · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache thrift
- Versiones
- ≥ 0, < 0.23.0: Afectada (semver)
Actualiza a 0.23.0
thrift Debian:12
- Versiones
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:13
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:14
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.23.0-3
Actualiza a 0.23.0-3
thrift Ubuntu:20.04:LTS
- Versiones
- 0.11.0-6
- 0.13.0-2build1
- 0.13.0-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:22.04:LTS
- Versiones
- 0.13.0-6ubuntu1
- 0.13.0-6ubuntu2
- 0.13.0-6ubuntu3
- 0.13.0-7
- 0.16.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:24.04:LTS
- Versiones
- 0.17.0-4
- 0.19.0-2
- 0.19.0-2build1
- 0.19.0-2.1build4
- 0.19.0-2.1build5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:25.10
- Versiones
- 0.19.0-4build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.10
- Versiones
- 0.22.0-3ubuntu1
- 0.23.0-3
- 0.23.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.04:LTS
- Versiones
- 0.19.0-4build1
- 0.22.0-3
- 0.22.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://lists.apache.org/thread/lb4j0zyd5f3g36cos0wql925przpnwql
- http://www.openwall.com/lists/oss-security/2026/04/28/8
- https://access.redhat.com/security/cve/CVE-2025-48431
- https://bugzilla.redhat.com/show_bug.cgi?id=2463410
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-48431.json
- https://access.redhat.com/errata/RHSA-2026:28010
- https://access.redhat.com/errata/RHSA-2026:36882
- https://access.redhat.com/errata/RHSA-2026:24539
- https://access.redhat.com/errata/RHSA-2026:25273
- https://access.redhat.com/errata/RHSA-2026:27126
- https://nvd.nist.gov/vuln/detail/CVE-2025-48431