CVE-2025-48431
CVE-2025-48431 · Apache Thrift: Specially crafted input can crash a c_glib Thrift server with invalid pointer error.
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Mismatched Memory Management Routines vulnerability in Apache Thrift c_glib language bindings. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. Description: Specially crafted requests can crash an c_glib-based Thrift server with a clean but fatal "free(): invalid pointer" error message.
CVSS 7.5 · Hoch · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
apache thrift
- Softwareversionen
- ≥ 0, < 0.23.0: Betroffen (semver)
Auf 0.23.0 aktualisieren
thrift Debian:12
- Softwareversionen
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Debian:13
- Softwareversionen
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Debian:14
- Softwareversionen
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.23.0-3
Auf 0.23.0-3 aktualisieren
thrift Ubuntu:20.04:LTS
- Softwareversionen
- 0.11.0-6
- 0.13.0-2build1
- 0.13.0-2build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:22.04:LTS
- Softwareversionen
- 0.13.0-6ubuntu1
- 0.13.0-6ubuntu2
- 0.13.0-6ubuntu3
- 0.13.0-7
- 0.16.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:24.04:LTS
- Softwareversionen
- 0.17.0-4
- 0.19.0-2
- 0.19.0-2build1
- 0.19.0-2.1build4
- 0.19.0-2.1build5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:25.10
- Softwareversionen
- 0.19.0-4build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:26.10
- Softwareversionen
- 0.22.0-3ubuntu1
- 0.23.0-3
- 0.23.0-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
thrift Ubuntu:26.04:LTS
- Softwareversionen
- 0.19.0-4build1
- 0.22.0-3
- 0.22.0-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://lists.apache.org/thread/lb4j0zyd5f3g36cos0wql925przpnwql
- http://www.openwall.com/lists/oss-security/2026/04/28/8
- https://access.redhat.com/security/cve/CVE-2025-48431
- https://bugzilla.redhat.com/show_bug.cgi?id=2463410
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-48431.json
- https://access.redhat.com/errata/RHSA-2026:28010
- https://access.redhat.com/errata/RHSA-2026:36882
- https://access.redhat.com/errata/RHSA-2026:24539
- https://access.redhat.com/errata/RHSA-2026:25273
- https://access.redhat.com/errata/RHSA-2026:27126
- https://nvd.nist.gov/vuln/detail/CVE-2025-48431