p PatchFirst

CVE-2025-49128

CVE-2025-49128 · Jackson-core Vulnerable to Memory Disclosure via Source Snippet in JsonLocation

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Jackson-core contains core low-level incremental ("streaming") parser and generator abstractions used by Jackson Data Processor. Starting in version 2.0.0 and prior to version 2.13.0, a flaw in jackson-core's `JsonLocation._appendSourceDesc` method allows up to 500 bytes of unintended memory content to be included in exception messages. When parsing JSON from a byte array with an offset and length, the exception message incorrectly reads from the beginning of the array instead of the logical payload start. This results in possible information disclosure in systems using pooled or reused buffers, like Netty or Vert.x. This issue was silently fixed in jackson-core version 2.13.0, released on September 30, 2021, via PR #652. All users should upgrade to version 2.13.0 or later. If upgrading is not immediately possible, applications can mitigate the issue by disabling exception message exposure to clients to avoid returning parsing exception messages in HTTP responses and/or disabling source inclusion in exceptions to prevent Jackson from embedding any source content in exception messages, avoiding leakage.

CVSS 4.0 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • jackson-core

    Versiones
    • >= 2.0.0, < 2.13.0: Afectada

    Sin corrección publicada

  • jackson-core Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.13.0-1

    Actualiza a 2.13.0-1

  • jackson-core Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.13.0-1

    Actualiza a 2.13.0-1

  • jackson-core Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.13.0-1

    Actualiza a 2.13.0-1

  • jackson-core Ubuntu:16.04:LTS

    Versiones
    • 2.4.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-core Ubuntu:18.04:LTS

    Versiones
    • 2.8.6-1
    • 2.9.1-1
    • 2.9.4-1
    • 2.9.8-3~18.04
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jackson-core Ubuntu:20.04:LTS

    Versiones
    • 2.9.8-3
    • 2.10.0-1
    • 2.10.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →