CVE-2025-54409
CVE-2025-54409 · AIDE null pointer dereference when reading incorrectly encoded xattr attributes from database (local DoS)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
AIDE is an advanced intrusion detection environment. From versions 0.13 to 0.19.1, there is a null pointer dereference vulnerability in AIDE. An attacker can crash the program during report printing or database listing after setting extended file attributes with an empty attribute value or with a key containing a comma. A local user might exploit this to cause a local denial of service. This issue has been patched in version 0.19.2. A workaround involves removing xattrs group from rules matching files on affected file systems.
CVSS 6.2 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
aide
- Versiones
- >= 0.13, < 0.19.2: Afectada
Sin corrección publicada
aide Debian:12
- Versiones
- 0.18.3-1
- 0.18.3-1+deb12u1
- 0.18.3-1+deb12u2
- 0.18.3-1+deb12u3
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.3-1+deb12u4
Actualiza a 0.18.3-1+deb12u4
aide Debian:13
- Versiones
- 0.19.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.19.1-2+deb13u1
Actualiza a 0.19.1-2+deb13u1
aide Debian:14
- Versiones
- 0.19.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.19.2-1
Actualiza a 0.19.2-1
aide Ubuntu:Pro:14.04:LTS
- Versiones
- 0.15.1-8ubuntu2
- 0.16~a2.git20130520-2
- 0.16~a2.git20130520-2ubuntu0.1
- 0.16~a2.git20130520-2ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16~a2.git20130520-2ubuntu0.1+esm2
Actualiza a 0.16~a2.git20130520-2ubuntu0.1+esm2
aide Ubuntu:Pro:16.04:LTS
- Versiones
- 0.16~a2.git20130520-3
- 0.16~a2.git20130520-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16~a2.git20130520-3ubuntu0.1~esm2
Actualiza a 0.16~a2.git20130520-3ubuntu0.1~esm2
aide Ubuntu:Pro:18.04:LTS
- Versiones
- 0.16-1
- 0.16-2
- 0.16-3
- 0.16-3ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16-3ubuntu0.1+esm1
Actualiza a 0.16-3ubuntu0.1+esm1
aide Ubuntu:Pro:20.04:LTS
- Versiones
- 0.16.1-1build2
- 0.16.1-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.1-1ubuntu0.1+esm1
Actualiza a 0.16.1-1ubuntu0.1+esm1
aide Ubuntu:22.04:LTS
- Versiones
- 0.17.3-4build1
- 0.17.3-5
- 0.17.4-1
- 0.17.4-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.17.4-1ubuntu0.2
Actualiza a 0.17.4-1ubuntu0.2
aide Ubuntu:24.04:LTS
- Versiones
- 0.18.5-1
- 0.18.6-2
- 0.18.6-2build1
- 0.18.6-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.6-2ubuntu0.1
Actualiza a 0.18.6-2ubuntu0.1
Fuentes originales
- https://github.com/aide/aide/security/advisories/GHSA-79g7-f8rv-jcxh
- https://github.com/aide/aide/commit/54a6d0d9d5f14b81961d66373c0291bf4af4135a
- https://github.com/aide/aide/releases/tag/v0.19.2
- https://lists.debian.org/debian-lts-announce/2025/08/msg00011.html
- http://www.openwall.com/lists/oss-security/2025/08/14/8
- https://nvd.nist.gov/vuln/detail/CVE-2025-54409