CVE-2025-54409
CVE-2025-54409 · AIDE null pointer dereference when reading incorrectly encoded xattr attributes from database (local DoS)
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
AIDE is an advanced intrusion detection environment. From versions 0.13 to 0.19.1, there is a null pointer dereference vulnerability in AIDE. An attacker can crash the program during report printing or database listing after setting extended file attributes with an empty attribute value or with a key containing a comma. A local user might exploit this to cause a local denial of service. This issue has been patched in version 0.19.2. A workaround involves removing xattrs group from rules matching files on affected file systems.
CVSS 6.2 · Moyenne · EPSS 0,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
aide
- Versions du logiciel
- >= 0.13, < 0.19.2: Concernée
Aucun correctif publié
aide Debian:12
- Versions du logiciel
- 0.18.3-1
- 0.18.3-1+deb12u1
- 0.18.3-1+deb12u2
- 0.18.3-1+deb12u3
- Plages de versions concernées
- ECOSYSTEM: < 0.18.3-1+deb12u4
Mettez à jour vers 0.18.3-1+deb12u4
aide Debian:13
- Versions du logiciel
- 0.19.1-2
- Plages de versions concernées
- ECOSYSTEM: < 0.19.1-2+deb13u1
Mettez à jour vers 0.19.1-2+deb13u1
aide Debian:14
- Versions du logiciel
- 0.19.1-2
- Plages de versions concernées
- ECOSYSTEM: < 0.19.2-1
Mettez à jour vers 0.19.2-1
aide Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 0.15.1-8ubuntu2
- 0.16~a2.git20130520-2
- 0.16~a2.git20130520-2ubuntu0.1
- 0.16~a2.git20130520-2ubuntu0.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 0.16~a2.git20130520-2ubuntu0.1+esm2
Mettez à jour vers 0.16~a2.git20130520-2ubuntu0.1+esm2
aide Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.16~a2.git20130520-3
- 0.16~a2.git20130520-3ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: < 0.16~a2.git20130520-3ubuntu0.1~esm2
Mettez à jour vers 0.16~a2.git20130520-3ubuntu0.1~esm2
aide Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 0.16-1
- 0.16-2
- 0.16-3
- 0.16-3ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 0.16-3ubuntu0.1+esm1
Mettez à jour vers 0.16-3ubuntu0.1+esm1
aide Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 0.16.1-1build2
- 0.16.1-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 0.16.1-1ubuntu0.1+esm1
Mettez à jour vers 0.16.1-1ubuntu0.1+esm1
aide Ubuntu:22.04:LTS
- Versions du logiciel
- 0.17.3-4build1
- 0.17.3-5
- 0.17.4-1
- 0.17.4-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 0.17.4-1ubuntu0.2
Mettez à jour vers 0.17.4-1ubuntu0.2
aide Ubuntu:24.04:LTS
- Versions du logiciel
- 0.18.5-1
- 0.18.6-2
- 0.18.6-2build1
- 0.18.6-2build2
- Plages de versions concernées
- ECOSYSTEM: < 0.18.6-2ubuntu0.1
Mettez à jour vers 0.18.6-2ubuntu0.1
Sources originales
- https://github.com/aide/aide/security/advisories/GHSA-79g7-f8rv-jcxh
- https://github.com/aide/aide/commit/54a6d0d9d5f14b81961d66373c0291bf4af4135a
- https://github.com/aide/aide/releases/tag/v0.19.2
- https://lists.debian.org/debian-lts-announce/2025/08/msg00011.html
- http://www.openwall.com/lists/oss-security/2025/08/14/8
- https://nvd.nist.gov/vuln/detail/CVE-2025-54409