CVE-2025-54433
CVE-2025-54433 · Bugsink is vulnerable to Path Traversal attacks via event_id in ingestion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Bugsink is a self-hosted error tracking service. In versions 1.4.2 and below, 1.5.0 through 1.5.4, 1.6.0 through 1.6.3, and 1.7.0 through 1.7.3, ingestion paths construct file locations directly from untrusted event_id input without validation. A specially crafted event_id can result in paths outside the intended directory, potentially allowing file overwrite or creation in arbitrary locations. Submitting such input requires access to a valid DSN, potentially exposing them. If Bugsink runs in a container, the effect is confined to the container’s filesystem. In non-containerized setups, the overwrite may affect other parts of the system accessible to that user. This is fixed in versions 1.4.3, 1.5.5, 1.6.4 and 1.7.4.
CVSS 7.2 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
bugsink
- Versiones
- >= 1.7.0, < 1.7.4: Afectada
- >= 1.6.0, < 1.6.4: Afectada
- >= 1.5.0, < 1.5.5: Afectada
- < 1.4.3: Afectada
Sin corrección publicada
bugsink PyPI
- Versiones
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.7.0, < 1.7.4
Actualiza a 1.7.4
bugsink PyPI
- Versiones
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.6.0, < 1.6.4
Actualiza a 1.6.4
bugsink PyPI
- Versiones
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.5.0, < 1.5.5
Actualiza a 1.5.5
bugsink PyPI
- Versiones
- 0.0.1
- 0.1.12
- 0.1.13
- 0.1.14
- 0.1.15
- 0.1.16
- 0.1.17
- 0.1.18
- 0.1.19
- 0.1.20
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.3
Actualiza a 1.4.3
bugsink PyPI
- Versiones
- 0.0.1
- 0.1.12
- 0.1.13
- 0.1.14
- 0.1.15
- 0.1.16
- 0.1.17
- 0.1.18
- 0.1.19
- 0.1.20
- 1.0.0
- 1.0.1
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.3 ∪ ≥ 1.5.0, < 1.5.5 ∪ ≥ 1.6.0, < 1.6.4 ∪ ≥ 1.7.0, < 1.7.4 ∪ ≥ 1.6.0, < 1.6.4
Actualiza a 1.4.3; Actualiza a 1.5.5; Actualiza a 1.6.4; Actualiza a 1.7.4
Fuentes originales
- https://github.com/bugsink/bugsink/security/advisories/GHSA-q78p-g86f-jg6q
- https://github.com/bugsink/bugsink/commit/1001726f4389e982c486cdd5fa81941cb46cfc33
- https://github.com/bugsink/bugsink/commit/211ddf76758c808c095b5f836c363f148d934d21
- https://github.com/bugsink/bugsink/commit/2c41fbe3881bdea83399a7f9fdc8cff198ae089f
- https://github.com/bugsink/bugsink/commit/53cf1a17a3e96f7c83c7451fd56f980a09d0c9b0
- https://github.com/bugsink/bugsink/commit/55a155003d0b416ea008c5e7dcde85130ad21d9b
- https://github.com/bugsink/bugsink/commit/b94aa8a5c96ce8cdd9711b6beb4e518264993ac2
- https://github.com/bugsink/bugsink/commit/c341687bd655543730c812db35c29199f788be6b
- https://github.com/bugsink/bugsink/commit/c87217bd565122ba70af90436e3ab2cd9bee658f
- https://nvd.nist.gov/vuln/detail/CVE-2025-54433