p PatchFirst

CVE-2025-54433

CVE-2025-54433 · Bugsink is vulnerable to Path Traversal attacks via event_id in ingestion

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Bugsink is a self-hosted error tracking service. In versions 1.4.2 and below, 1.5.0 through 1.5.4, 1.6.0 through 1.6.3, and 1.7.0 through 1.7.3, ingestion paths construct file locations directly from untrusted event_id input without validation. A specially crafted event_id can result in paths outside the intended directory, potentially allowing file overwrite or creation in arbitrary locations. Submitting such input requires access to a valid DSN, potentially exposing them. If Bugsink runs in a container, the effect is confined to the container’s filesystem. In non-containerized setups, the overwrite may affect other parts of the system accessible to that user. This is fixed in versions 1.4.3, 1.5.5, 1.6.4 and 1.7.4.

CVSS 7.2 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • bugsink

    Softwareversionen
    • >= 1.7.0, < 1.7.4: Betroffen
    • >= 1.6.0, < 1.6.4: Betroffen
    • >= 1.5.0, < 1.5.5: Betroffen
    • < 1.4.3: Betroffen

    Keine Korrektur veröffentlicht

  • bugsink PyPI

    Softwareversionen
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.7.0, < 1.7.4

    Auf 1.7.4 aktualisieren

  • bugsink PyPI

    Softwareversionen
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.6.0, < 1.6.4

    Auf 1.6.4 aktualisieren

  • bugsink PyPI

    Softwareversionen
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.5.0, < 1.5.5

    Auf 1.5.5 aktualisieren

  • bugsink PyPI

    Softwareversionen
    • 0.0.1
    • 0.1.12
    • 0.1.13
    • 0.1.14
    • 0.1.15
    • 0.1.16
    • 0.1.17
    • 0.1.18
    • 0.1.19
    • 0.1.20
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.3

    Auf 1.4.3 aktualisieren

  • bugsink PyPI

    Softwareversionen
    • 0.0.1
    • 0.1.12
    • 0.1.13
    • 0.1.14
    • 0.1.15
    • 0.1.16
    • 0.1.17
    • 0.1.18
    • 0.1.19
    • 0.1.20
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.3 ∪ ≥ 1.5.0, < 1.5.5 ∪ ≥ 1.6.0, < 1.6.4 ∪ ≥ 1.7.0, < 1.7.4 ∪ ≥ 1.6.0, < 1.6.4

    Auf 1.4.3 aktualisieren; Auf 1.5.5 aktualisieren; Auf 1.6.4 aktualisieren; Auf 1.7.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →