CVE-2025-54584
CVE-2025-54584 · GitProxy is vulnerable to a packfile parsing exploit
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
GitProxy is an application that stands between developers and a Git remote endpoint (e.g., github.com). In versions 1.19.1 and below, an attacker can craft a malicious Git packfile to exploit the PACK signature detection in the parsePush.ts file. By embedding a misleading PACK signature within commit content and carefully constructing the packet structure, the attacker can trick the parser into treating invalid or unintended data as the packfile. Potentially, this would allow bypassing approval or hiding commits. This issue is fixed in version 1.19.2.
CVSS 7.0 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
git-proxy
- Versiones
- < 1.19.2: Afectada
Sin corrección publicada
@finos/git-proxy npm
- Intervalos de versiones afectados
- SEMVER: < 1.19.2
Actualiza a 1.19.2
Fuentes originales
- https://github.com/finos/git-proxy/security/advisories/GHSA-xxmh-rf63-qwjv
- https://github.com/finos/git-proxy/commit/333c98a165a5a1ec88414db3d4a2c6f81e083e0f
- https://github.com/finos/git-proxy/commit/a620a2f33c39c78e01783a274580bf822af3cc3a
- https://github.com/finos/git-proxy/releases/tag/v1.19.2
- https://nvd.nist.gov/vuln/detail/CVE-2025-54584