p PatchFirst

CVE-2025-54584

CVE-2025-54584 · GitProxy is vulnerable to a packfile parsing exploit

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GitProxy is an application that stands between developers and a Git remote endpoint (e.g., github.com). In versions 1.19.1 and below, an attacker can craft a malicious Git packfile to exploit the PACK signature detection in the parsePush.ts file. By embedding a misleading PACK signature within commit content and carefully constructing the packet structure, the attacker can trick the parser into treating invalid or unintended data as the packfile. Potentially, this would allow bypassing approval or hiding commits. This issue is fixed in version 1.19.2.

CVSS 7.0 · Hoch · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • git-proxy

    Softwareversionen
    • < 1.19.2: Betroffen

    Keine Korrektur veröffentlicht

  • @finos/git-proxy npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.19.2

    Auf 1.19.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →