CVE-2025-59036
CVE-2025-59036 · Infrahub allows authentication with deleted and expired API tokens
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Infrahub offers a central hub to manage data, templates, and playbooks. Prior to versiond 1.3.9 and 1.4.5, a bug in the authentication logic will cause API tokens that were deleted and/or expired to be considered valid. This means that any API token that is associated with an active user account can authenticate successfully. This issue is fixed in versions 1.3.9 and 1.4.5. As a workaround, users can delete or deactivate the account associated with a deleted API token to prevent that token from authenticating.
CVSS 5.5 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
infrahub
- Versiones
- < 1.3.9: Afectada
- >= 1.4.0, < 1.4.5: Afectada
Sin corrección publicada
infrahub-server PyPI
- Versiones
- 1.0.1
- 1.0.10
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.0b2
- 1.1.1
- 1.1.10
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0b1
- 1.2.0rc0
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.12
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.2.9rc0
- 1.3.0
- 1.3.0a0
- 1.3.0b1
- 1.3.0b2
- 1.3.0b3
- 1.3.0b5
- 1.3.0b6
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.9
Actualiza a 1.3.9
infrahub-server PyPI
- Versiones
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.4.0, < 1.4.5
Actualiza a 1.4.5
infrahub-server PyPI
- Versiones
- 1.0.1
- 1.0.10
- 1.0.8
- 1.0.9
- 1.1.0
- 1.1.0b2
- 1.1.1
- 1.1.10
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.1.7
- 1.1.8
- 1.1.9
- 1.2.0
- 1.2.0b1
- 1.2.0rc0
- 1.2.1
- 1.2.10
- 1.2.11
- 1.2.12
- 1.2.2
- 1.2.3
- 1.2.4
- 1.2.5
- 1.2.6
- 1.2.7
- 1.2.8
- 1.2.9
- 1.2.9rc0
- 1.3.0
- 1.3.0a0
- 1.3.0b1
- 1.3.0b2
- 1.3.0b3
- 1.3.0b5
- 1.3.0b6
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.9 ∪ ≥ 1.4.0, < 1.4.5
Actualiza a 1.3.9; Actualiza a 1.4.5