p PatchFirst

CVE-2025-59419

CVE-2025-59419 · Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.128.Final and 4.2.7.Final, the SMTP codec in Netty contains an SMTP command injection vulnerability due to insufficient input validation for Carriage Return (\r) and Line Feed (\n) characters in user-supplied parameters. The vulnerability exists in io.netty.handler.codec.smtp.DefaultSmtpRequest, where parameters are directly concatenated into the SMTP command string without sanitization. When methods such as SmtpRequests.rcpt(recipient) are called with a malicious string containing CRLF sequences, attackers can inject arbitrary SMTP commands. Because the injected commands are sent from the server's trusted IP address, resulting emails will likely pass SPF and DKIM authentication checks, making them appear legitimate. This allows remote attackers who can control SMTP command parameters (such as email recipients) to forge arbitrary emails from the trusted server, potentially impersonating executives and forging high-stakes corporate communications. This issue has been patched in versions 4.1.129.Final and 4.2.8.Final. No known workarounds exist.

CVSS 5.5 · Media · EPSS 1,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • netty

    Versiones
    • < 4.2.7.Final: Afectada
    • >= 4.2.0.Alpha1, < 4.1.128.Final: Afectada

    Sin corrección publicada

  • netty Debian:12

    Versiones
    • 1:4.1.48-7
    • 1:4.1.48-7+deb12u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-7+deb12u2

    Actualiza a 1:4.1.48-7+deb12u2

  • netty Debian:13

    Versiones
    • 1:4.1.48-10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-10+deb13u1

    Actualiza a 1:4.1.48-10+deb13u1

  • netty Debian:14

    Versiones
    • 1:4.1.48-10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-11

    Actualiza a 1:4.1.48-11

  • netty Ubuntu:Pro:18.04:LTS

    Versiones
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    • 1:4.1.7-4ubuntu0.1+esm2
    • 1:4.1.7-4ubuntu0.1+esm3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm4

    Actualiza a 1:4.1.7-4ubuntu0.1+esm4

  • netty Ubuntu:Pro:20.04:LTS

    Versiones
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    • 1:4.1.45-1ubuntu0.1~esm1
    • 1:4.1.45-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm3

    Actualiza a 1:4.1.45-1ubuntu0.1~esm3

  • netty Ubuntu:Pro:22.04:LTS

    Versiones
    • 1:4.1.48-4
    • 1:4.1.48-4+deb11u1build0.22.04.1
    • 1:4.1.48-4+deb11u2build0.22.04.1
    • 1:4.1.48-4+deb11u2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1~esm2

    Actualiza a 1:4.1.48-4+deb11u2ubuntu0.1~esm2

  • netty Ubuntu:Pro:24.04:LTS

    Versiones
    • 1:4.1.48-7
    • 1:4.1.48-8
    • 1:4.1.48-9
    • 1:4.1.48-9ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-9ubuntu0.1~esm2

    Actualiza a 1:4.1.48-9ubuntu0.1~esm2

  • netty Ubuntu:25.10

    Versiones
    • 1:4.1.48-10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.1

    Actualiza a 1:4.1.48-10ubuntu0.25.10.1

  • netty Ubuntu:26.10

    Versiones
    • 1:4.1.48-16
    • 1:4.1.48-16ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • netty Ubuntu:Pro:26.04:LTS

    Versiones
    • 1:4.1.48-10
    • 1:4.1.48-11
    • 1:4.1.48-12
    • 1:4.1.48-13
    • 1:4.1.48-14
    • 1:4.1.48-16
    • 1:4.1.48-16ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →