CVE-2025-59419
CVE-2025-59419 · Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.128.Final and 4.2.7.Final, the SMTP codec in Netty contains an SMTP command injection vulnerability due to insufficient input validation for Carriage Return (\r) and Line Feed (\n) characters in user-supplied parameters. The vulnerability exists in io.netty.handler.codec.smtp.DefaultSmtpRequest, where parameters are directly concatenated into the SMTP command string without sanitization. When methods such as SmtpRequests.rcpt(recipient) are called with a malicious string containing CRLF sequences, attackers can inject arbitrary SMTP commands. Because the injected commands are sent from the server's trusted IP address, resulting emails will likely pass SPF and DKIM authentication checks, making them appear legitimate. This allows remote attackers who can control SMTP command parameters (such as email recipients) to forge arbitrary emails from the trusted server, potentially impersonating executives and forging high-stakes corporate communications. This issue has been patched in versions 4.1.129.Final and 4.2.8.Final. No known workarounds exist.
CVSS 5.5 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
netty
- Versions
- < 4.2.7.Final: Affected
- >= 4.2.0.Alpha1, < 4.1.128.Final: Affected
No fix published
netty Debian:12
- Versions
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Update to 1:4.1.48-7+deb12u2
netty Debian:13
- Versions
- 1:4.1.48-10
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-10+deb13u1
Update to 1:4.1.48-10+deb13u1
netty Debian:14
- Versions
- 1:4.1.48-10
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-11
Update to 1:4.1.48-11
netty Ubuntu:Pro:18.04:LTS
- Versions
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- 1:4.1.7-4ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm4
Update to 1:4.1.7-4ubuntu0.1+esm4
netty Ubuntu:Pro:20.04:LTS
- Versions
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- 1:4.1.45-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm3
Update to 1:4.1.45-1ubuntu0.1~esm3
netty Ubuntu:Pro:22.04:LTS
- Versions
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- 1:4.1.48-4+deb11u2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1~esm2
Update to 1:4.1.48-4+deb11u2ubuntu0.1~esm2
netty Ubuntu:Pro:24.04:LTS
- Versions
- 1:4.1.48-7
- 1:4.1.48-8
- 1:4.1.48-9
- 1:4.1.48-9ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-9ubuntu0.1~esm2
Update to 1:4.1.48-9ubuntu0.1~esm2
netty Ubuntu:25.10
- Versions
- 1:4.1.48-10
- Affected ranges
- ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.1
Update to 1:4.1.48-10ubuntu0.25.10.1
netty Ubuntu:26.10
- Versions
- 1:4.1.48-16
- 1:4.1.48-16ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
netty Ubuntu:Pro:26.04:LTS
- Versions
- 1:4.1.48-10
- 1:4.1.48-11
- 1:4.1.48-12
- 1:4.1.48-13
- 1:4.1.48-14
- 1:4.1.48-16
- 1:4.1.48-16ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/netty/netty/security/advisories/GHSA-jq43-27x9-3v86
- https://github.com/netty/netty/commit/1782e8c2060a244c4d4e6f9d9112d5517ca05120
- https://www.depthfirst.com/post/our-ai-agent-found-a-netty-zero-day-that-bypasses-email-authentication-the-story-of-cve-2025-59419
- https://nvd.nist.gov/vuln/detail/CVE-2025-59419