CVE-2025-61622
CVE-2025-61622 · Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.
CVSS 9.8 · Crítica · EPSS 45,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
apache fory
- Versiones
- ≥ 0.12.0, ≤ 0.12.2: Afectada (semver)
Sin corrección publicada
apache fory
- Versiones
- ≥ 0.1.0, ≤ 0.10.3: Afectada (semver)
Sin corrección publicada
pyfory PyPI
- Versiones
- 0.12.0
- 0.12.1
- 0.12.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.12.0, < 0.12.3
Actualiza a 0.12.3
pyfury PyPI
- Versiones
- 0.10.2
- 0.10.2rc1
- 0.10.3
- 0.2.0
- 0.2.0a1
- 0.2.1
- 0.2.1a1
- 0.3.0
- 0.3.0a1
- 0.3.0a2
- 0.3.0a3
- 0.3.1
- 0.4.0
- 0.4.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.1.0, ≤ 0.10.3
Sin corrección publicada