p PatchFirst

CVE-2025-61622

CVE-2025-61622 · Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Deserialization of untrusted data in python in pyfory versions 0.12.0 through 0.12.2, or the legacy pyfury versions from 0.1.0 through 0.10.3: allows arbitrary code execution. An application is vulnerable if it reads pyfory serialized data from untrusted sources. An attacker can craft a data stream that selects pickle-fallback serializer during deserialization, leading to the execution of `pickle.loads`, which is vulnerable to remote code execution. Users are recommended to upgrade to pyfory version 0.12.3 or later, which has removed pickle fallback serializer and thus fixes this issue.

CVSS 9.8 · Kritisch · EPSS 45,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache fory

    Softwareversionen
    • ≥ 0.12.0, ≤ 0.12.2: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • apache fory

    Softwareversionen
    • ≥ 0.1.0, ≤ 0.10.3: Betroffen (semver)

    Keine Korrektur veröffentlicht

  • pyfory PyPI

    Softwareversionen
    • 0.12.0
    • 0.12.1
    • 0.12.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.12.0, < 0.12.3

    Auf 0.12.3 aktualisieren

  • pyfury PyPI

    Softwareversionen
    • 0.10.2
    • 0.10.2rc1
    • 0.10.3
    • 0.2.0
    • 0.2.0a1
    • 0.2.1
    • 0.2.1a1
    • 0.3.0
    • 0.3.0a1
    • 0.3.0a2
    • 0.3.0a3
    • 0.3.1
    • 0.4.0
    • 0.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.1.0, ≤ 0.10.3

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →