p PatchFirst

CVE-2025-6167

CVE-2025-6167 · themanojdesai python-a2a api.py create_workflow path traversal

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 5.1 · Media · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • python-a2a

    Versiones
    • 0.5.0: Afectada
    • 0.5.1: Afectada
    • 0.5.2: Afectada
    • 0.5.3: Afectada
    • 0.5.4: Afectada
    • 0.5.5: Afectada
    • 0.5.6: No afectada

    Actualiza a 0.5.6

  • python-a2a PyPI

    Versiones
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.5.6

    Actualiza a 0.5.6

  • python-a2a PyPI

    Versiones
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • v0.5.5
    • v0.5.4
    • v0.5.3
    • v0.5.2
    • v0.5.1
    • v0.5.0
    • v0.4.6
    • v0.4.5
    • v0.4.4
    • v0.4.3a
    • v0.4.3
    Intervalos de versiones afectados
    • GIT: < f486b53625698b7d03561d176dfe98f5d1528276
    • ECOSYSTEM: < 0.5.6

    Actualiza a 0.5.6

Fuentes originales

Comprueba tu servidor →