p PatchFirst

CVE-2025-6167

CVE-2025-6167 · themanojdesai python-a2a api.py create_workflow path traversal

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability classified as critical has been found in themanojdesai python-a2a up to 0.5.5. Affected is the function create_workflow of the file python_a2a/agent_flow/server/api.py. The manipulation leads to path traversal. Upgrading to version 0.5.6 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 5.1 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • python-a2a

    Versions
    • 0.5.0: Affected
    • 0.5.1: Affected
    • 0.5.2: Affected
    • 0.5.3: Affected
    • 0.5.4: Affected
    • 0.5.5: Affected
    • 0.5.6: Not affected

    Update to 0.5.6

  • python-a2a PyPI

    Versions
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    Affected ranges
    • ECOSYSTEM: < 0.5.6

    Update to 0.5.6

  • python-a2a PyPI

    Versions
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • 0.4.3a0
    • 0.4.4
    • 0.4.5
    • 0.4.6
    • 0.5.0
    • 0.5.1
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • v0.5.5
    • v0.5.4
    • v0.5.3
    • v0.5.2
    • v0.5.1
    • v0.5.0
    • v0.4.6
    • v0.4.5
    • v0.4.4
    • v0.4.3a
    • v0.4.3
    Affected ranges
    • GIT: < f486b53625698b7d03561d176dfe98f5d1528276
    • ECOSYSTEM: < 0.5.6

    Update to 0.5.6

Original sources

Check your server →