p PatchFirst

CVE-2025-62164

CVE-2025-62164 · VLLM deserialization vulnerability leading to DoS and potential RCE

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

CVSS 8.8 · Alta · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • vllm

    Versiones
    • >= 0.10.2, < 0.11.1: Afectada

    Sin corrección publicada

  • vllm PyPI

    Versiones
    • 0.10.2
    • 0.11.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.10.2, < 0.11.1

    Actualiza a 0.11.1

Fuentes originales

Comprueba tu servidor →