p PatchFirst

CVE-2025-62164

CVE-2025-62164 · VLLM deserialization vulnerability leading to DoS and potential RCE

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

CVSS 8.8 · Élevée · EPSS 1,0% · Correctif disponible

Publication
Mise à jour

Pile logicielle: python

Produits et versions concernés

  • vllm

    Versions du logiciel
    • >= 0.10.2, < 0.11.1: Concernée

    Aucun correctif publié

  • vllm PyPI

    Versions du logiciel
    • 0.10.2
    • 0.11.0
    Plages de versions concernées
    • ECOSYSTEM: ≥ 0.10.2, < 0.11.1

    Mettez à jour vers 0.11.1

Sources originales

Vérifiez votre serveur →