CVE-2025-6375
CVE-2025-6375 · poco MultipartReader.cpp MultipartInputStream null pointer dereference
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.
CVSS 4.8 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
poco
- Versiones
- 1.14.0: Afectada
- 1.14.1: Afectada
- 1.14.2: No afectada
Actualiza a 1.14.2
poco Debian:12
- Versiones
- 1.11.0-3
- 1.11.0-3+deb12u1
- 1.11.0-3+hurd.1
- 1.11.0-4
- 1.11.0-4.1
- 1.13.0-1
- 1.13.0-2
- 1.13.0-3
- 1.13.0-4
- 1.13.0-5
- 1.13.0-6
- 1.14.2-1
- 1.14.2-2
- 1.14.2-3
- 1.14.2-4
- 1.14.2-5
- 1.14.2-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Debian:13
- Versiones
- 1.13.0-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.13.0-6+deb13u1
Actualiza a 1.13.0-6+deb13u1
poco Debian:14
- Versiones
- 1.13.0-6
- 1.14.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.2-2
Actualiza a 1.14.2-2
poco Ubuntu:14.04:LTS
- Versiones
- 1.3.6p1-4
- 1.3.6p1-4+deb7u1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:16.04:LTS
- Versiones
- 1.3.6p1-5.1
- 1.3.6p1-5.1build1
- 1.3.6p1-5.1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:18.04:LTS
- Versiones
- 1.7.8+dfsg1-2
- 1.7.8+dfsg1-3
- 1.8.0.1-1ubuntu4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:20.04:LTS
- Versiones
- 1.9.2-3ubuntu2
- 1.9.2-3ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:22.04:LTS
- Versiones
- 1.10.0-6
- 1.11.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:24.04:LTS
- Versiones
- 1.11.0-3
- 1.11.0-4
- 1.11.0-4.1
- 1.11.0-4.1build1
- 1.11.0-4.1build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:25.10
- Versiones
- 1.13.0-6build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:26.10
- Versiones
- 1.14.2-3
- 1.14.2-6
- 1.14.2-6ubuntu1
- 1.14.2-6ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
poco Ubuntu:26.04:LTS
- Versiones
- 1.13.0-6build2
- 1.14.2-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://vuldb.com/?id.313370
- https://vuldb.com/?ctiid.313370
- https://vuldb.com/?submit.597446
- https://github.com/pocoproject/poco/issues/4915
- https://github.com/user-attachments/files/19524599/poco_crash.txt
- https://github.com/pocoproject/poco/commit/6f2f85913c191ab9ddfb8fae781f5d66afccf3bf
- https://github.com/pocoproject/poco/releases/tag/poco-1.14.2-release
- https://nvd.nist.gov/vuln/detail/CVE-2025-6375