CVE-2025-6375
CVE-2025-6375 · poco MultipartReader.cpp MultipartInputStream null pointer dereference
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability was found in poco up to 1.14.1. It has been rated as problematic. Affected by this issue is the function MultipartInputStream of the file Net/src/MultipartReader.cpp. The manipulation leads to null pointer dereference. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.14.2 is able to address this issue. The patch is identified as 6f2f85913c191ab9ddfb8fae781f5d66afccf3bf. It is recommended to upgrade the affected component.
CVSS 4.8 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
poco
- Softwareversionen
- 1.14.0: Betroffen
- 1.14.1: Betroffen
- 1.14.2: Nicht betroffen
Auf 1.14.2 aktualisieren
poco Debian:12
- Softwareversionen
- 1.11.0-3
- 1.11.0-3+deb12u1
- 1.11.0-3+hurd.1
- 1.11.0-4
- 1.11.0-4.1
- 1.13.0-1
- 1.13.0-2
- 1.13.0-3
- 1.13.0-4
- 1.13.0-5
- 1.13.0-6
- 1.14.2-1
- 1.14.2-2
- 1.14.2-3
- 1.14.2-4
- 1.14.2-5
- 1.14.2-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Debian:13
- Softwareversionen
- 1.13.0-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.13.0-6+deb13u1
Auf 1.13.0-6+deb13u1 aktualisieren
poco Debian:14
- Softwareversionen
- 1.13.0-6
- 1.14.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.14.2-2
Auf 1.14.2-2 aktualisieren
poco Ubuntu:14.04:LTS
- Softwareversionen
- 1.3.6p1-4
- 1.3.6p1-4+deb7u1build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:16.04:LTS
- Softwareversionen
- 1.3.6p1-5.1
- 1.3.6p1-5.1build1
- 1.3.6p1-5.1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:18.04:LTS
- Softwareversionen
- 1.7.8+dfsg1-2
- 1.7.8+dfsg1-3
- 1.8.0.1-1ubuntu4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:20.04:LTS
- Softwareversionen
- 1.9.2-3ubuntu2
- 1.9.2-3ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:22.04:LTS
- Softwareversionen
- 1.10.0-6
- 1.11.0-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:24.04:LTS
- Softwareversionen
- 1.11.0-3
- 1.11.0-4
- 1.11.0-4.1
- 1.11.0-4.1build1
- 1.11.0-4.1build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:25.10
- Softwareversionen
- 1.13.0-6build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:26.10
- Softwareversionen
- 1.14.2-3
- 1.14.2-6
- 1.14.2-6ubuntu1
- 1.14.2-6ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
poco Ubuntu:26.04:LTS
- Softwareversionen
- 1.13.0-6build2
- 1.14.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://vuldb.com/?id.313370
- https://vuldb.com/?ctiid.313370
- https://vuldb.com/?submit.597446
- https://github.com/pocoproject/poco/issues/4915
- https://github.com/user-attachments/files/19524599/poco_crash.txt
- https://github.com/pocoproject/poco/commit/6f2f85913c191ab9ddfb8fae781f5d66afccf3bf
- https://github.com/pocoproject/poco/releases/tag/poco-1.14.2-release
- https://nvd.nist.gov/vuln/detail/CVE-2025-6375