CVE-2025-65015
CVE-2025-65015 · joserfc has Possible Uncontrolled Resource Consumption Vulnerability Triggered by Logging Arbitrarily Large JWT Token Payloads
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. In versions from 1.3.3 to before 1.3.5 and from 1.4.0 to before 1.4.2, the ExceededSizeError exception messages are embedded with non-decoded JWT token parts and may cause Python logging to record an arbitrarily large, forged JWT payload. In situations where a misconfigured — or entirely absent — production-grade web server sits in front of a Python web application, an attacker may be able to send arbitrarily large bearer tokens in the HTTP request headers. When this occurs, Python logging or diagnostic tools (e.g., Sentry) may end up processing extremely large log messages containing the full JWT header during the joserfc.jwt.decode() operation. The same behavior also appears when validating claims and signature payload sizes, as the library raises joserfc.errors.ExceededSizeError() with the full payload embedded in the exception message. Since the payload is already fully loaded into memory at this stage, the library cannot prevent or reject it. This issue has been patched in versions 1.3.5 and 1.4.2.
CVSS 9.2 · Crítica · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
joserfc
- Versiones
- >= 1.3.3, < 1.3.5: Afectada
- >= 1.4.0, < 1.4.2: Afectada
Sin corrección publicada
joserfc Debian:14
- Versiones
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- 1.3.1-1
- 1.3.2-1
- 1.3.4-1
- 1.4.0-1
- 1.4.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.3-1
Actualiza a 1.4.3-1
joserfc PyPI
- Versiones
- 1.3.3
- 1.3.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.3.3, < 1.3.5
Actualiza a 1.3.5
joserfc PyPI
- Versiones
- 1.4.0
- 1.4.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.4.0, < 1.4.2
Actualiza a 1.4.2
joserfc PyPI
- Versiones
- 1.3.3
- 1.3.4
- 1.4.0
- 1.4.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.3.3, < 1.3.5 ∪ ≥ 1.4.0, < 1.4.2
Actualiza a 1.3.5; Actualiza a 1.4.2
joserfc Ubuntu:25.10
- Versiones
- 1.0.4-1
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
joserfc Ubuntu:26.10
- Versiones
- 1.6.2-1
- 1.6.5-1
- 1.6.8-1
- 1.7.0-1
- 1.7.1-1
- 1.7.2-1
- 1.7.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
joserfc Ubuntu:26.04:LTS
- Versiones
- 1.2.2-1
- 1.4.0-1
- 1.4.1-1
- 1.4.3-1
- 1.5.0-1
- 1.6.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/authlib/joserfc/security/advisories/GHSA-frfh-8v73-gjg4
- https://github.com/authlib/joserfc/commit/63932f169d924caffafa761af2122b82059017f7
- https://github.com/authlib/joserfc/commit/673c8743fd0605b0e1de6452be6cba75f44e466b
- https://github.com/authlib/joserfc/releases/tag/1.3.5
- https://github.com/authlib/joserfc/releases/tag/1.4.2
- https://nvd.nist.gov/vuln/detail/CVE-2025-65015