CVE-2025-65015
CVE-2025-65015 · joserfc has Possible Uncontrolled Resource Consumption Vulnerability Triggered by Logging Arbitrarily Large JWT Token Payloads
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. In versions from 1.3.3 to before 1.3.5 and from 1.4.0 to before 1.4.2, the ExceededSizeError exception messages are embedded with non-decoded JWT token parts and may cause Python logging to record an arbitrarily large, forged JWT payload. In situations where a misconfigured — or entirely absent — production-grade web server sits in front of a Python web application, an attacker may be able to send arbitrarily large bearer tokens in the HTTP request headers. When this occurs, Python logging or diagnostic tools (e.g., Sentry) may end up processing extremely large log messages containing the full JWT header during the joserfc.jwt.decode() operation. The same behavior also appears when validating claims and signature payload sizes, as the library raises joserfc.errors.ExceededSizeError() with the full payload embedded in the exception message. Since the payload is already fully loaded into memory at this stage, the library cannot prevent or reject it. This issue has been patched in versions 1.3.5 and 1.4.2.
CVSS 9.2 · Critique · EPSS 0,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
joserfc
- Versions du logiciel
- >= 1.3.3, < 1.3.5: Concernée
- >= 1.4.0, < 1.4.2: Concernée
Aucun correctif publié
joserfc Debian:14
- Versions du logiciel
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- 1.3.1-1
- 1.3.2-1
- 1.3.4-1
- 1.4.0-1
- 1.4.1-1
- Plages de versions concernées
- ECOSYSTEM: < 1.4.3-1
Mettez à jour vers 1.4.3-1
joserfc PyPI
- Versions du logiciel
- 1.3.3
- 1.3.4
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.3.3, < 1.3.5
Mettez à jour vers 1.3.5
joserfc PyPI
- Versions du logiciel
- 1.4.0
- 1.4.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.4.0, < 1.4.2
Mettez à jour vers 1.4.2
joserfc PyPI
- Versions du logiciel
- 1.3.3
- 1.3.4
- 1.4.0
- 1.4.1
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.3.3, < 1.3.5 ∪ ≥ 1.4.0, < 1.4.2
Mettez à jour vers 1.3.5; Mettez à jour vers 1.4.2
joserfc Ubuntu:25.10
- Versions du logiciel
- 1.0.4-1
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
joserfc Ubuntu:26.10
- Versions du logiciel
- 1.6.2-1
- 1.6.5-1
- 1.6.8-1
- 1.7.0-1
- 1.7.1-1
- 1.7.2-1
- 1.7.4-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
joserfc Ubuntu:26.04:LTS
- Versions du logiciel
- 1.2.2-1
- 1.4.0-1
- 1.4.1-1
- 1.4.3-1
- 1.5.0-1
- 1.6.2-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/authlib/joserfc/security/advisories/GHSA-frfh-8v73-gjg4
- https://github.com/authlib/joserfc/commit/63932f169d924caffafa761af2122b82059017f7
- https://github.com/authlib/joserfc/commit/673c8743fd0605b0e1de6452be6cba75f44e466b
- https://github.com/authlib/joserfc/releases/tag/1.3.5
- https://github.com/authlib/joserfc/releases/tag/1.4.2
- https://nvd.nist.gov/vuln/detail/CVE-2025-65015