p PatchFirst

CVE-2025-66457

CVE-2025-66457 · Elysia affected by arbitrary code injection through cookie config

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.

CVSS 7.5 · Alta · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • elysia

    Versiones
    • < 1.4.18: Afectada

    Sin corrección publicada

  • elysia npm

    Intervalos de versiones afectados
    • SEMVER: < 1.4.18

    Actualiza a 1.4.18

Fuentes originales

Comprueba tu servidor →