p PatchFirst

CVE-2025-66457

CVE-2025-66457 · Elysia affected by arbitrary code injection through cookie config

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g. there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.

CVSS 7.5 · Élevée · EPSS 0,8% · Correctif disponible

Publication
Mise à jour

Pile logicielle: node

Produits et versions concernés

  • elysia

    Versions du logiciel
    • < 1.4.18: Concernée

    Aucun correctif publié

  • elysia npm

    Plages de versions concernées
    • SEMVER: < 1.4.18

    Mettez à jour vers 1.4.18

Sources originales

Vérifiez votre serveur →