p PatchFirst

CVE-2025-6965

CVE-2025-6965 · Integer Truncation on SQLite

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

CVSS 7.2 · Alta · EPSS 73,5% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • sqlite

    Versiones
    • ≥ 0, < 3.50.2: Afectada (semver)

    Actualiza a 3.50.2

  • sqlite3 Debian:12

    Versiones
    • 3.40.1-2
    • 3.40.1-2+deb12u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.40.1-2+deb12u2

    Actualiza a 3.40.1-2+deb12u2

  • sqlite3 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.46.1-7

    Actualiza a 3.46.1-7

  • sqlite3 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.46.1-7

    Actualiza a 3.46.1-7

  • sqlite3 Ubuntu:Pro:14.04:LTS

    Versiones
    • 3.7.17-1ubuntu1
    • 3.8.0.2-1ubuntu1
    • 3.8.1-1ubuntu1
    • 3.8.1-1ubuntu3
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu2
    • 3.8.2-1ubuntu2.1
    • 3.8.2-1ubuntu2.2
    • 3.8.2-1ubuntu2.2+esm1
    • 3.8.2-1ubuntu2.2+esm2
    • 3.8.2-1ubuntu2.2+esm3
    • 3.8.2-1ubuntu2.2+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.8.2-1ubuntu2.2+esm5

    Actualiza a 3.8.2-1ubuntu2.2+esm5

  • sqlite3 Ubuntu:Pro:16.04:LTS

    Versiones
    • 3.8.11.1-1
    • 3.9.1-2
    • 3.9.2-1
    • 3.10.0-1
    • 3.10.1-1
    • 3.10.2-1
    • 3.11.0-1ubuntu1
    • 3.11.0-1ubuntu1.1
    • 3.11.0-1ubuntu1.2
    • 3.11.0-1ubuntu1.3
    • 3.11.0-1ubuntu1.4
    • 3.11.0-1ubuntu1.5
    • 3.11.0-1ubuntu1.5+esm1
    • 3.11.0-1ubuntu1.5+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.11.0-1ubuntu1.5+esm3

    Actualiza a 3.11.0-1ubuntu1.5+esm3

  • sqlite3 Ubuntu:Pro:18.04:LTS

    Versiones
    • 3.19.3-3
    • 3.20.1-2
    • 3.21.0-1
    • 3.22.0-1
    • 3.22.0-1ubuntu0.1
    • 3.22.0-1ubuntu0.2
    • 3.22.0-1ubuntu0.3
    • 3.22.0-1ubuntu0.4
    • 3.22.0-1ubuntu0.5
    • 3.22.0-1ubuntu0.6
    • 3.22.0-1ubuntu0.7
    • 3.22.0-1ubuntu0.7+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.22.0-1ubuntu0.7+esm2

    Actualiza a 3.22.0-1ubuntu0.7+esm2

  • sqlite3 Ubuntu:Pro:20.04:LTS

    Versiones
    • 3.29.0-2
    • 3.30.1-1
    • 3.30.1-1ubuntu1
    • 3.31.1-1ubuntu1
    • 3.31.1-3
    • 3.31.1-4
    • 3.31.1-4ubuntu0.1
    • 3.31.1-4ubuntu0.2
    • 3.31.1-4ubuntu0.3
    • 3.31.1-4ubuntu0.4
    • 3.31.1-4ubuntu0.5
    • 3.31.1-4ubuntu0.6
    • 3.31.1-4ubuntu0.7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.31.1-4ubuntu0.7+esm1

    Actualiza a 3.31.1-4ubuntu0.7+esm1

  • sqlite3 Ubuntu:22.04:LTS

    Versiones
    • 3.35.5-1
    • 3.36.0-2
    • 3.37.2-2
    • 3.37.2-2ubuntu0.1
    • 3.37.2-2ubuntu0.3
    • 3.37.2-2ubuntu0.4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.37.2-2ubuntu0.5

    Actualiza a 3.37.2-2ubuntu0.5

  • sqlite3 Ubuntu:24.04:LTS

    Versiones
    • 3.42.0-1
    • 3.44.0-1
    • 3.44.2-1
    • 3.45.0-1
    • 3.45.1-1
    • 3.45.1-1ubuntu1
    • 3.45.1-1ubuntu2
    • 3.45.1-1ubuntu2.1
    • 3.45.1-1ubuntu2.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.45.1-1ubuntu2.4

    Actualiza a 3.45.1-1ubuntu2.4

  • sqlite3 Ubuntu:25.10

    Versiones
    • 3.46.1-3
    • 3.46.1-4
    • 3.46.1-6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.46.1-6ubuntu1

    Actualiza a 3.46.1-6ubuntu1

Fuentes originales

Comprueba tu servidor →