p PatchFirst

CVE-2025-6965

CVE-2025-6965 · Integer Truncation on SQLite

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.

CVSS 7.2 · Hoch · EPSS 73,5% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • sqlite

    Softwareversionen
    • ≥ 0, < 3.50.2: Betroffen (semver)

    Auf 3.50.2 aktualisieren

  • sqlite3 Debian:12

    Softwareversionen
    • 3.40.1-2
    • 3.40.1-2+deb12u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.40.1-2+deb12u2

    Auf 3.40.1-2+deb12u2 aktualisieren

  • sqlite3 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.46.1-7

    Auf 3.46.1-7 aktualisieren

  • sqlite3 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.46.1-7

    Auf 3.46.1-7 aktualisieren

  • sqlite3 Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 3.7.17-1ubuntu1
    • 3.8.0.2-1ubuntu1
    • 3.8.1-1ubuntu1
    • 3.8.1-1ubuntu3
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu2
    • 3.8.2-1ubuntu2.1
    • 3.8.2-1ubuntu2.2
    • 3.8.2-1ubuntu2.2+esm1
    • 3.8.2-1ubuntu2.2+esm2
    • 3.8.2-1ubuntu2.2+esm3
    • 3.8.2-1ubuntu2.2+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.8.2-1ubuntu2.2+esm5

    Auf 3.8.2-1ubuntu2.2+esm5 aktualisieren

  • sqlite3 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 3.8.11.1-1
    • 3.9.1-2
    • 3.9.2-1
    • 3.10.0-1
    • 3.10.1-1
    • 3.10.2-1
    • 3.11.0-1ubuntu1
    • 3.11.0-1ubuntu1.1
    • 3.11.0-1ubuntu1.2
    • 3.11.0-1ubuntu1.3
    • 3.11.0-1ubuntu1.4
    • 3.11.0-1ubuntu1.5
    • 3.11.0-1ubuntu1.5+esm1
    • 3.11.0-1ubuntu1.5+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.11.0-1ubuntu1.5+esm3

    Auf 3.11.0-1ubuntu1.5+esm3 aktualisieren

  • sqlite3 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 3.19.3-3
    • 3.20.1-2
    • 3.21.0-1
    • 3.22.0-1
    • 3.22.0-1ubuntu0.1
    • 3.22.0-1ubuntu0.2
    • 3.22.0-1ubuntu0.3
    • 3.22.0-1ubuntu0.4
    • 3.22.0-1ubuntu0.5
    • 3.22.0-1ubuntu0.6
    • 3.22.0-1ubuntu0.7
    • 3.22.0-1ubuntu0.7+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.22.0-1ubuntu0.7+esm2

    Auf 3.22.0-1ubuntu0.7+esm2 aktualisieren

  • sqlite3 Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 3.29.0-2
    • 3.30.1-1
    • 3.30.1-1ubuntu1
    • 3.31.1-1ubuntu1
    • 3.31.1-3
    • 3.31.1-4
    • 3.31.1-4ubuntu0.1
    • 3.31.1-4ubuntu0.2
    • 3.31.1-4ubuntu0.3
    • 3.31.1-4ubuntu0.4
    • 3.31.1-4ubuntu0.5
    • 3.31.1-4ubuntu0.6
    • 3.31.1-4ubuntu0.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.31.1-4ubuntu0.7+esm1

    Auf 3.31.1-4ubuntu0.7+esm1 aktualisieren

  • sqlite3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.35.5-1
    • 3.36.0-2
    • 3.37.2-2
    • 3.37.2-2ubuntu0.1
    • 3.37.2-2ubuntu0.3
    • 3.37.2-2ubuntu0.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.37.2-2ubuntu0.5

    Auf 3.37.2-2ubuntu0.5 aktualisieren

  • sqlite3 Ubuntu:24.04:LTS

    Softwareversionen
    • 3.42.0-1
    • 3.44.0-1
    • 3.44.2-1
    • 3.45.0-1
    • 3.45.1-1
    • 3.45.1-1ubuntu1
    • 3.45.1-1ubuntu2
    • 3.45.1-1ubuntu2.1
    • 3.45.1-1ubuntu2.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.45.1-1ubuntu2.4

    Auf 3.45.1-1ubuntu2.4 aktualisieren

  • sqlite3 Ubuntu:25.10

    Softwareversionen
    • 3.46.1-3
    • 3.46.1-4
    • 3.46.1-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.46.1-6ubuntu1

    Auf 3.46.1-6ubuntu1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →