CVE-2025-7339
CVE-2025-7339 · on-headers vulnerable to http response header manipulation
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()`. Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.
CVSS 3.4 · Baja · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
on-headers
- Versiones
- ≥ 0, < 1.1.0: Afectada (semver)
Actualiza a 1.1.0
node-on-headers Debian:12
- Versiones
- 1.0.2-2
- 1.0.2-4
- 1.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2-4
Actualiza a 1.0.2-4
node-on-headers Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2-4
Actualiza a 1.0.2-4
on-headers npm
- Intervalos de versiones afectados
- SEMVER: < 1.1.0
Actualiza a 1.1.0
node-on-headers Ubuntu:16.04:LTS
- Versiones
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:18.04:LTS
- Versiones
- 1.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:20.04:LTS
- Versiones
- 1.0.1-1
- 1.0.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:22.04:LTS
- Versiones
- 1.0.2-1
- 1.0.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:24.04:LTS
- Versiones
- 1.0.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:25.10
- Versiones
- 1.0.2-2
- 1.0.2-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:26.10
- Versiones
- 1.0.2-4
- 1.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-on-headers Ubuntu:26.04:LTS
- Versiones
- 1.0.2-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/jshttp/on-headers/security/advisories/GHSA-76c9-3jph-rj3q
- https://github.com/jshttp/on-headers/commit/c6e384908c9c6127d18831d16ab0bd96e1231867
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/morgan/issues/315
- https://github.com/jshttp/on-headers/issues/15
- https://nvd.nist.gov/vuln/detail/CVE-2025-7339