p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de node-on-headers

Vulnerabilidades publicadas para node-on-headers en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidad: 1

  1. CVE-2025-7339

    Baja · CVSS 3.4EPSS 0,21%Corrección disponible

    on-headers vulnerable to http response header manipulation

    on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is passed to `response.writeHead()`. Users should upgrade to version 1.1.0 to receive a patch. Uses are strongly encouraged to upgrade to `1.1.0`, but this issue can be worked around by passing an object to `response.writeHead()` rather than an array.

    • Actualiza a 1.0.2-4
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →