CVE-2026-102271
CVE-2026-102271 · PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PyJWT is a Python implementation of JSON Web Token standards. From 2.4.0 until 2.14.0, PyJWT HMACAlgorithm.prepare_key is affected because asymmetric-key guard relies on textual markers that are absent from DER encoding. This occurs when an application mixes HMAC and asymmetric algorithms and supplies a DER public key as the shared verification key. As a result, PyJWT uses public DER bytes as an HMAC secret. Consequently, an attacker who knows the public key can forge authenticated HMAC tokens. This issue is fixed in version 2.14.0.
CVSS 7.4 · Alta · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
pyjwt
- Versiones
- >= 2.4.0, < 2.14.0: Afectada
Sin corrección publicada
pyjwt Debian:12
- Versiones
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:13
- Versiones
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:14
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.14.0-1
Actualiza a 2.14.0-1
pyjwt PyPI
- Versiones
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.4.0, < 2.14.0
Actualiza a 2.14.0
pyjwt Ubuntu:Pro:16.04:LTS
- Versiones
- 1.0.0-0ubuntu1
- 1.3.0-1
- 1.3.0-1ubuntu0.1
- 1.3.0-1ubuntu0.1+esm1
- 1.3.0-1ubuntu0.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm3
Actualiza a 1.3.0-1ubuntu0.1+esm3
pyjwt Ubuntu:Pro:18.04:LTS
- Versiones
- 1.4.2-1.1
- 1.5.3+ds1-1
- 1.5.3+ds1-1ubuntu0.1
- 1.5.3+ds1-1ubuntu0.1+esm1
- 1.5.3+ds1-1ubuntu0.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm3
Actualiza a 1.5.3+ds1-1ubuntu0.1+esm3
pyjwt Ubuntu:Pro:20.04:LTS
- Versiones
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- 1.7.1-2ubuntu2.1
- 1.7.1-2ubuntu2.1+esm1
- 1.7.1-2ubuntu2.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm3
Actualiza a 1.7.1-2ubuntu2.1+esm3
pyjwt Ubuntu:22.04:LTS
- Versiones
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.0-1ubuntu0.5
Actualiza a 2.3.0-1ubuntu0.5
pyjwt Ubuntu:24.04:LTS
- Versiones
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.0-1ubuntu0.3
Actualiza a 2.7.0-1ubuntu0.3
pyjwt Ubuntu:26.10
- Versiones
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.13.0-1ubuntu1
Actualiza a 2.13.0-1ubuntu1
pyjwt Ubuntu:26.04:LTS
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10.1-4ubuntu1.2
Actualiza a 2.10.1-4ubuntu1.2