CVE-2026-102271
CVE-2026-102271 · PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
PyJWT is a Python implementation of JSON Web Token standards. From 2.4.0 until 2.14.0, PyJWT HMACAlgorithm.prepare_key is affected because asymmetric-key guard relies on textual markers that are absent from DER encoding. This occurs when an application mixes HMAC and asymmetric algorithms and supplies a DER public key as the shared verification key. As a result, PyJWT uses public DER bytes as an HMAC secret. Consequently, an attacker who knows the public key can forge authenticated HMAC tokens. This issue is fixed in version 2.14.0.
CVSS 7.4 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
pyjwt
- Softwareversionen
- >= 2.4.0, < 2.14.0: Betroffen
Keine Korrektur veröffentlicht
pyjwt Debian:12
- Softwareversionen
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:13
- Softwareversionen
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pyjwt Debian:14
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.14.0-1
Auf 2.14.0-1 aktualisieren
pyjwt PyPI
- Softwareversionen
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0, < 2.14.0
Auf 2.14.0 aktualisieren
pyjwt Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.0.0-0ubuntu1
- 1.3.0-1
- 1.3.0-1ubuntu0.1
- 1.3.0-1ubuntu0.1+esm1
- 1.3.0-1ubuntu0.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.3.0-1ubuntu0.1+esm3
Auf 1.3.0-1ubuntu0.1+esm3 aktualisieren
pyjwt Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.4.2-1.1
- 1.5.3+ds1-1
- 1.5.3+ds1-1ubuntu0.1
- 1.5.3+ds1-1ubuntu0.1+esm1
- 1.5.3+ds1-1ubuntu0.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1+esm3
Auf 1.5.3+ds1-1ubuntu0.1+esm3 aktualisieren
pyjwt Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- 1.7.1-2ubuntu2.1
- 1.7.1-2ubuntu2.1+esm1
- 1.7.1-2ubuntu2.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.7.1-2ubuntu2.1+esm3
Auf 1.7.1-2ubuntu2.1+esm3 aktualisieren
pyjwt Ubuntu:22.04:LTS
- Softwareversionen
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.0-1ubuntu0.5
Auf 2.3.0-1ubuntu0.5 aktualisieren
pyjwt Ubuntu:24.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0-1ubuntu0.3
Auf 2.7.0-1ubuntu0.3 aktualisieren
pyjwt Ubuntu:26.10
- Softwareversionen
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.13.0-1ubuntu1
Auf 2.13.0-1ubuntu1 aktualisieren
pyjwt Ubuntu:26.04:LTS
- Softwareversionen
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.10.1-4ubuntu1.2
Auf 2.10.1-4ubuntu1.2 aktualisieren