CVE-2026-102276
CVE-2026-102276 · brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.
CVSS 7.5 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
brace-expansion
- Versiones
- >= 4.0.0, < 5.0.10: Afectada
- >= 3.0.0, < 3.0.7: Afectada
- >= 2.0.0, < 2.1.5: Afectada
- < 1.1.19: Afectada
Sin corrección publicada
node-brace-expansion Debian:12
- Versiones
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Debian:13
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Debian:14
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.7+~1.1.2-1
Actualiza a 2.1.7+~1.1.2-1
brace-expansion npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 5.0.10
Actualiza a 5.0.10
brace-expansion npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.0.0, < 3.0.7
Actualiza a 3.0.7
brace-expansion npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0, < 2.1.5
Actualiza a 2.1.5
brace-expansion npm
- Intervalos de versiones afectados
- SEMVER: < 1.1.19
Actualiza a 1.1.19
node-brace-expansion Ubuntu:18.04:LTS
- Versiones
- 1.1.8-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:20.04:LTS
- Versiones
- 1.1.8-1
- 1.1.11-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:22.04:LTS
- Versiones
- 2.0.0-1
- 2.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:24.04:LTS
- Versiones
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:26.10
- Versiones
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-brace-expansion Ubuntu:26.04:LTS
- Versiones
- 2.0.1+~1.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-6j4f-fj2g-mc7p
- https://github.com/juliangruber/brace-expansion/commit/0bcbfc0a5928c3073d48f42999d1ce4fc1c42fbc
- https://github.com/juliangruber/brace-expansion/commit/316359e6019c39b3254c8ba8e25dc586a480652c
- https://github.com/juliangruber/brace-expansion/commit/5171e681c0922b7ae8bfaf9a331e309107be6edc
- https://github.com/juliangruber/brace-expansion/commit/6735c94873ca570bcdd6a0690033bdd3126379d3
- https://nvd.nist.gov/vuln/detail/CVE-2026-102276