CVE-2026-102276
CVE-2026-102276 · brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.
CVSS 7.5 · Hoch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
brace-expansion
- Softwareversionen
- >= 4.0.0, < 5.0.10: Betroffen
- >= 3.0.0, < 3.0.7: Betroffen
- >= 2.0.0, < 2.1.5: Betroffen
- < 1.1.19: Betroffen
Keine Korrektur veröffentlicht
node-brace-expansion Debian:12
- Softwareversionen
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Debian:13
- Softwareversionen
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Debian:14
- Softwareversionen
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.7+~1.1.2-1
Auf 2.1.7+~1.1.2-1 aktualisieren
brace-expansion npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 4.0.0, < 5.0.10
Auf 5.0.10 aktualisieren
brace-expansion npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.0.7
Auf 3.0.7 aktualisieren
brace-expansion npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.1.5
Auf 2.1.5 aktualisieren
brace-expansion npm
- Betroffene Versionsbereiche
- SEMVER: < 1.1.19
Auf 1.1.19 aktualisieren
node-brace-expansion Ubuntu:18.04:LTS
- Softwareversionen
- 1.1.8-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Ubuntu:20.04:LTS
- Softwareversionen
- 1.1.8-1
- 1.1.11-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Ubuntu:22.04:LTS
- Softwareversionen
- 2.0.0-1
- 2.0.1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Ubuntu:24.04:LTS
- Softwareversionen
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Ubuntu:26.10
- Softwareversionen
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-brace-expansion Ubuntu:26.04:LTS
- Softwareversionen
- 2.0.1+~1.1.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-6j4f-fj2g-mc7p
- https://github.com/juliangruber/brace-expansion/commit/0bcbfc0a5928c3073d48f42999d1ce4fc1c42fbc
- https://github.com/juliangruber/brace-expansion/commit/316359e6019c39b3254c8ba8e25dc586a480652c
- https://github.com/juliangruber/brace-expansion/commit/5171e681c0922b7ae8bfaf9a331e309107be6edc
- https://github.com/juliangruber/brace-expansion/commit/6735c94873ca570bcdd6a0690033bdd3126379d3
- https://nvd.nist.gov/vuln/detail/CVE-2026-102276