p PatchFirst

CVE-2026-102277

CVE-2026-102277 · brace-expansion: Quadratic-time expansion of the `{a},b}` rewrite causes CPU denial of service

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.21, 2.1.7, 3.0.9, and 5.0.12, the expand function handles untrusted {a},b}-shaped patterns with many trailing closing braces by restarting its scan once for each trailing closing brace. The successive full-input rescans with linear working-string growth cause quadratic CPU time and memory pressure that can block the Node.js event loop. The process eventually recovers, making the impact a recoverable CPU denial of service. This issue is fixed in versions 1.1.21, 2.1.7, 3.0.9, and 5.0.12.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • brace-expansion

    Versiones
    • >= 4.0.0, < 5.0.12: Afectada
    • >= 3.0.0, < 3.0.9: Afectada
    • >= 2.0.0, < 2.1.7: Afectada
    • < 1.1.21: Afectada

    Sin corrección publicada

  • node-brace-expansion Debian:12

    Versiones
    • 2.0.1+~1.1.0-1
    • 2.0.1+~1.1.0-2
    • 2.0.1-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Debian:13

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    • 2.1.7+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Debian:14

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-1
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.7+~1.1.2-1

    Actualiza a 2.1.7+~1.1.2-1

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 5.0.12

    Actualiza a 5.0.12

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.0.0, < 3.0.9

    Actualiza a 3.0.9

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.1.7

    Actualiza a 2.1.7

  • brace-expansion npm

    Intervalos de versiones afectados
    • SEMVER: < 1.1.21

    Actualiza a 1.1.21

  • node-brace-expansion Ubuntu:18.04:LTS

    Versiones
    • 1.1.8-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:20.04:LTS

    Versiones
    • 1.1.8-1
    • 1.1.11-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:22.04:LTS

    Versiones
    • 2.0.0-1
    • 2.0.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:24.04:LTS

    Versiones
    • 2.0.1-2
    • 2.0.1+~1.1.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:26.10

    Versiones
    • 2.0.1+~1.1.0-2
    • 2.0.3+~1.1.2-2
    • 2.0.3+~1.1.2-3
    • 2.1.4+~1.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-brace-expansion Ubuntu:26.04:LTS

    Versiones
    • 2.0.1+~1.1.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →