CVE-2026-102277
CVE-2026-102277 · brace-expansion: Quadratic-time expansion of the `{a},b}` rewrite causes CPU denial of service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.21, 2.1.7, 3.0.9, and 5.0.12, the expand function handles untrusted {a},b}-shaped patterns with many trailing closing braces by restarting its scan once for each trailing closing brace. The successive full-input rescans with linear working-string growth cause quadratic CPU time and memory pressure that can block the Node.js event loop. The process eventually recovers, making the impact a recoverable CPU denial of service. This issue is fixed in versions 1.1.21, 2.1.7, 3.0.9, and 5.0.12.
CVSS 5.3 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
brace-expansion
- Versions
- >= 4.0.0, < 5.0.12: Affected
- >= 3.0.0, < 3.0.9: Affected
- >= 2.0.0, < 2.1.7: Affected
- < 1.1.21: Affected
No fix published
node-brace-expansion Debian:12
- Versions
- 2.0.1+~1.1.0-1
- 2.0.1+~1.1.0-2
- 2.0.1-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Debian:13
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- 2.1.7+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Debian:14
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-1
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Affected ranges
- ECOSYSTEM: < 2.1.7+~1.1.2-1
Update to 2.1.7+~1.1.2-1
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 5.0.12
Update to 5.0.12
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 3.0.0, < 3.0.9
Update to 3.0.9
brace-expansion npm
- Affected ranges
- SEMVER: ≥ 2.0.0, < 2.1.7
Update to 2.1.7
brace-expansion npm
- Affected ranges
- SEMVER: < 1.1.21
Update to 1.1.21
node-brace-expansion Ubuntu:18.04:LTS
- Versions
- 1.1.8-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:20.04:LTS
- Versions
- 1.1.8-1
- 1.1.11-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:22.04:LTS
- Versions
- 2.0.0-1
- 2.0.1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:24.04:LTS
- Versions
- 2.0.1-2
- 2.0.1+~1.1.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:26.10
- Versions
- 2.0.1+~1.1.0-2
- 2.0.3+~1.1.2-2
- 2.0.3+~1.1.2-3
- 2.1.4+~1.1.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
node-brace-expansion Ubuntu:26.04:LTS
- Versions
- 2.0.1+~1.1.0-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-q2hr-2g5m-vwhr
- https://github.com/juliangruber/brace-expansion/commit/33a5ef17b8d800bbfa8c52b14c39043b6aac1a96
- https://github.com/juliangruber/brace-expansion/commit/bdff773f98e5988616b7039cc9b508df5d640b22
- https://github.com/juliangruber/brace-expansion/commit/c55e67d8d8b1c56a2474afff15c2891166b2d364
- https://github.com/juliangruber/brace-expansion/commit/ffdfa3e3806bed17c0874b8f1439b084de354a7e
- https://nvd.nist.gov/vuln/detail/CVE-2026-102277