CVE-2026-111759
CVE-2026-111759 · markdown-it: Quadratic complexity in smartquotes with unmatched closing quotes
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
markdown-it is a Markdown parser. Prior to 14.3.2 and 15.0.2, when typographer: true is enabled, specially crafted Markdown can cause quadratic processing time in the smartquotes rule, potentially leading to denial of service in applications processing untrusted input. Many opening double quotes followed by unmatched closing single quotes cause repeated scans of the entire opener stack. The same issue occurs with the quote types reversed. The default configuration (typographer: false) is not affected, but this option is enabled with high probability. This issue is fixed in versions 14.3.2 and 15.0.2.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
markdown-it
- Versiones
- >= 15.0.0, < 15.0.2: Afectada
- < 14.3.2: Afectada
Sin corrección publicada
node-markdown-it Debian:12
- Versiones
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-markdown-it Debian:13
- Versiones
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-markdown-it Debian:14
- Versiones
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
markdown-it npm
- Intervalos de versiones afectados
- SEMVER: ≥ 15.0.0, < 15.0.2
Actualiza a 15.0.2
markdown-it npm
- Intervalos de versiones afectados
- SEMVER: < 14.3.2
Actualiza a 14.3.2
node-markdown-it Ubuntu:22.04:LTS
- Versiones
- 10.0.0+dfsg-2
- 10.0.0+dfsg-3
- 10.0.0+dfsg-3.1
- 10.0.0+dfsg-4
- 10.0.0+dfsg-5
- 10.0.0+dfsg-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-markdown-it Ubuntu:24.04:LTS
- Versiones
- 22.2.3+dfsg+~12.2.3-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-markdown-it Ubuntu:26.10
- Versiones
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-markdown-it Ubuntu:26.04:LTS
- Versiones
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/markdown-it/markdown-it/security/advisories/GHSA-r7fv-28h4-cvq7
- https://github.com/markdown-it/markdown-it/commit/1b379c1b6d0522421bd1a51b77337c79af2c8670
- https://github.com/markdown-it/markdown-it/commit/cf27366035edf9196667110c47d9d67b030a4152
- https://github.com/markdown-it/markdown-it/commit/daf5a3c32303e5d9de01b12eeb725fb5990b8162
- https://github.com/markdown-it/markdown-it/releases/tag/14.3.2
- https://github.com/markdown-it/markdown-it/releases/tag/15.0.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-111759