CVE-2026-111759
CVE-2026-111759 · markdown-it: Quadratic complexity in smartquotes with unmatched closing quotes
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
markdown-it is a Markdown parser. Prior to 14.3.2 and 15.0.2, when typographer: true is enabled, specially crafted Markdown can cause quadratic processing time in the smartquotes rule, potentially leading to denial of service in applications processing untrusted input. Many opening double quotes followed by unmatched closing single quotes cause repeated scans of the entire opener stack. The same issue occurs with the quote types reversed. The default configuration (typographer: false) is not affected, but this option is enabled with high probability. This issue is fixed in versions 14.3.2 and 15.0.2.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
markdown-it
- Softwareversionen
- >= 15.0.0, < 15.0.2: Betroffen
- < 14.3.2: Betroffen
Keine Korrektur veröffentlicht
node-markdown-it Debian:12
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-markdown-it Debian:13
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-markdown-it Debian:14
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-3
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
markdown-it npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 15.0.0, < 15.0.2
Auf 15.0.2 aktualisieren
markdown-it npm
- Betroffene Versionsbereiche
- SEMVER: < 14.3.2
Auf 14.3.2 aktualisieren
node-markdown-it Ubuntu:22.04:LTS
- Softwareversionen
- 10.0.0+dfsg-2
- 10.0.0+dfsg-3
- 10.0.0+dfsg-3.1
- 10.0.0+dfsg-4
- 10.0.0+dfsg-5
- 10.0.0+dfsg-6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-markdown-it Ubuntu:24.04:LTS
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-markdown-it Ubuntu:26.10
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-4
- 22.2.3+dfsg+~12.2.3-5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-markdown-it Ubuntu:26.04:LTS
- Softwareversionen
- 22.2.3+dfsg+~12.2.3-2
- 22.2.3+dfsg+~12.2.3-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/markdown-it/markdown-it/security/advisories/GHSA-r7fv-28h4-cvq7
- https://github.com/markdown-it/markdown-it/commit/1b379c1b6d0522421bd1a51b77337c79af2c8670
- https://github.com/markdown-it/markdown-it/commit/cf27366035edf9196667110c47d9d67b030a4152
- https://github.com/markdown-it/markdown-it/commit/daf5a3c32303e5d9de01b12eeb725fb5990b8162
- https://github.com/markdown-it/markdown-it/releases/tag/14.3.2
- https://github.com/markdown-it/markdown-it/releases/tag/15.0.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-111759