CVE-2026-112105
CVE-2026-112105 · GlitterWare Passy TLS main.dart MyHttpOverrides certificate validation
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability has been found in GlitterWare Passy up to 1.10.1. The affected element is the function MyHttpOverrides in the library lib/main.dart of the component TLS Handler. Such manipulation leads to improper certificate validation. The attack may be launched remotely. This attack is characterized by high complexity. The exploitability is described as difficult. Upgrading to version 1.10.2 is sufficient to fix this issue. The name of the patch is 3d48df7cce05e39fa4de1e42768492307f26882e. The affected component should be upgraded.
CVSS 6.3 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Productos y versiones afectados
passy
- Versiones
- 1.10.0: Afectada
- 1.10.1: Afectada
- 1.10.2: No afectada
Actualiza a 1.10.2
Fuentes originales
- https://vuldb.com/vuln/422055
- https://vuldb.com/vuln/422055/cti
- https://vuldb.com/cve/CVE-2026-112105
- https://vuldb.com/submit/1013135
- https://github.com/GlitterWare/Passy/issues/210
- https://github.com/GlitterWare/Passy/commit/3d48df7cce05e39fa4de1e42768492307f26882e
- https://github.com/GlitterWare/Passy/releases/tag/v1.10.2
- https://github.com/GlitterWare/Passy/
- https://nvd.nist.gov/vuln/detail/CVE-2026-112105