CVE-2026-112947
CVE-2026-112947 · Vite: First 4 bytes of files outside of `server.fs` setting is exposed by `?vite-wasm-instance`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Vite is a frontend tooling framework for JavaScript. From 8.2.0 until 8.2.4 and 8.3.3, the first 4 bytes of files outside of server.fs setting can be returned to the browser by a request containing ?vite-wasm-instance. Requests containing the ?vite-wasm-instance query are handled by the internal Wasm plugin's load hook. The hook removes the query and reads the resulting path directly from disk, but the server.fs checks were not applied. After reading the file, Vite attempts to parse it as WebAssembly. When that parse fails, Node and deno throws an error that contains the first 4 bytes of the file. This vulnerability is fixed in 8.2.4 and 8.3.3.
CVSS 6.3 · Media · EPSS 0,5% · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
vite
- Versiones
- >= 8.3.0, < 8.3.3: Afectada
- >= 8.2.0, < 8.2.4: Afectada
Sin corrección publicada
vite-plus
- Versiones
- >= 0.2.8, < 1.1.0: Afectada
Sin corrección publicada
vite npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.3.0, < 8.3.3
Actualiza a 8.3.3
vite npm
- Intervalos de versiones afectados
- SEMVER: ≥ 8.2.0, < 8.2.4
Actualiza a 8.2.4
vite-plus npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.2.8, < 1.1.0
Actualiza a 1.1.0
vite Ubuntu:16.04:LTS
- Versiones
- 1.2+svn1430-2
- 1.2+svn1430-3
- 1.2+svn1430-4
- 1.2+svn1430-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:18.04:LTS
- Versiones
- 1.2+svn1430-5
- 1.2+svn1430-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:20.04:LTS
- Versiones
- 1.2+svn1430-6
- 1.2+svn1430-6build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:22.04:LTS
- Versiones
- 1.2+svn+git4.c6c0ce7-3
- 1.2+svn+git4.c6c0ce7-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:24.04:LTS
- Versiones
- 1.2+svn+git4.c6c0ce7-8
- 1.2+svn+git4.c6c0ce7-8build1
- 1.2+svn+git4.c6c0ce7-8build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:26.10
- Versiones
- 1.4-6
- 1.4-6build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
vite Ubuntu:26.04:LTS
- Versiones
- 1.4-1
- 1.4-5
- 1.4-5build1
- 1.4-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/vitejs/vite/security/advisories/GHSA-vfpm-58rq-9qcg
- https://github.com/vitejs/vite/pull/23655
- https://github.com/vitejs/vite/commit/b6c6d2fb3f853aab4092dc25f0d6816a96c23dff
- https://github.com/vitejs/vite/commit/ba8b7ab43b4afa5d0292ab4b6e3a7b5033cc9c73
- https://nvd.nist.gov/vuln/detail/CVE-2026-112947