CVE-2026-112947
CVE-2026-112947 · Vite: First 4 bytes of files outside of `server.fs` setting is exposed by `?vite-wasm-instance`
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Vite is a frontend tooling framework for JavaScript. From 8.2.0 until 8.2.4 and 8.3.3, the first 4 bytes of files outside of server.fs setting can be returned to the browser by a request containing ?vite-wasm-instance. Requests containing the ?vite-wasm-instance query are handled by the internal Wasm plugin's load hook. The hook removes the query and reads the resulting path directly from disk, but the server.fs checks were not applied. After reading the file, Vite attempts to parse it as WebAssembly. When that parse fails, Node and deno throws an error that contains the first 4 bytes of the file. This vulnerability is fixed in 8.2.4 and 8.3.3.
CVSS 6.3 · Moyenne · EPSS 0,5% · Code d’exploitation public · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · node
Produits et versions concernés
vite
- Versions du logiciel
- >= 8.3.0, < 8.3.3: Concernée
- >= 8.2.0, < 8.2.4: Concernée
Aucun correctif publié
vite-plus
- Versions du logiciel
- >= 0.2.8, < 1.1.0: Concernée
Aucun correctif publié
vite npm
- Plages de versions concernées
- SEMVER: ≥ 8.3.0, < 8.3.3
Mettez à jour vers 8.3.3
vite npm
- Plages de versions concernées
- SEMVER: ≥ 8.2.0, < 8.2.4
Mettez à jour vers 8.2.4
vite-plus npm
- Plages de versions concernées
- SEMVER: ≥ 0.2.8, < 1.1.0
Mettez à jour vers 1.1.0
vite Ubuntu:16.04:LTS
- Versions du logiciel
- 1.2+svn1430-2
- 1.2+svn1430-3
- 1.2+svn1430-4
- 1.2+svn1430-5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:18.04:LTS
- Versions du logiciel
- 1.2+svn1430-5
- 1.2+svn1430-6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:20.04:LTS
- Versions du logiciel
- 1.2+svn1430-6
- 1.2+svn1430-6build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:22.04:LTS
- Versions du logiciel
- 1.2+svn+git4.c6c0ce7-3
- 1.2+svn+git4.c6c0ce7-4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:24.04:LTS
- Versions du logiciel
- 1.2+svn+git4.c6c0ce7-8
- 1.2+svn+git4.c6c0ce7-8build1
- 1.2+svn+git4.c6c0ce7-8build2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:26.10
- Versions du logiciel
- 1.4-6
- 1.4-6build1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
vite Ubuntu:26.04:LTS
- Versions du logiciel
- 1.4-1
- 1.4-5
- 1.4-5build1
- 1.4-6
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/vitejs/vite/security/advisories/GHSA-vfpm-58rq-9qcg
- https://github.com/vitejs/vite/pull/23655
- https://github.com/vitejs/vite/commit/b6c6d2fb3f853aab4092dc25f0d6816a96c23dff
- https://github.com/vitejs/vite/commit/ba8b7ab43b4afa5d0292ab4b6e3a7b5033cc9c73
- https://nvd.nist.gov/vuln/detail/CVE-2026-112947